summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthäus G. Chajdas <Anteru@users.noreply.github.com>2019-12-19 07:22:37 +0100
committerGitHub <noreply@github.com>2019-12-19 07:22:37 +0100
commit95cd525bc6a4fdcfaff243f70ee03d07124ed0cb (patch)
treec3dbf98310f6b3ea07381d208fd8a52be0a38b4d
parent29d2789f9fd3784652de2f20585db9a3fd9a7e76 (diff)
parent9486f826b9729c7d3e94ddb69d6869598dfb0419 (diff)
downloadpygments-git-95cd525bc6a4fdcfaff243f70ee03d07124ed0cb.tar.gz
Merge pull request #1339 from kurtmckee/update-http-urls
Update many links to use HTTPS and skip redirects
-rw-r--r--CHANGES2
-rw-r--r--doc/docs/integrate.rst4
-rw-r--r--doc/docs/java.rst8
-rw-r--r--doc/docs/lexerdevelopment.rst2
-rw-r--r--doc/docs/moinmoin.rst2
-rw-r--r--doc/docs/plugins.rst4
-rw-r--r--doc/docs/rstdirective.rst2
-rw-r--r--doc/faq.rst34
-rw-r--r--doc/languages.rst38
-rw-r--r--external/rst-directive.py4
-rw-r--r--pygments/formatters/html.py4
-rwxr-xr-xsetup.py2
12 files changed, 53 insertions, 53 deletions
diff --git a/CHANGES b/CHANGES
index 6ac44302..049fe4c0 100644
--- a/CHANGES
+++ b/CHANGES
@@ -808,7 +808,7 @@ Version 1.4
- Support ``application/javascript`` as a JavaScript mime type (#504).
-- Support `Offload <http://offload.codeplay.com>`_ C++ Extensions as
+- Support `Offload <https://offload.codeplay.com/>`_ C++ Extensions as
keywords in the C++ lexer (#484).
- Escape more characters in LaTeX output (#505).
diff --git a/doc/docs/integrate.rst b/doc/docs/integrate.rst
index 77daaa43..5f266ac5 100644
--- a/doc/docs/integrate.rst
+++ b/doc/docs/integrate.rst
@@ -12,7 +12,7 @@ that uses Pygments to render source code in
:file:`external/markdown-processor.py`. You can copy and adapt it to your
liking.
-.. _Markdown: http://www.freewisdom.org/projects/python-markdown/
+.. _Markdown: https://pypi.org/project/Markdown/
TextMate
--------
@@ -20,7 +20,7 @@ TextMate
Antonio Cangiano has created a Pygments bundle for TextMate that allows to
colorize code via a simple menu option. It can be found here_.
-.. _here: http://antoniocangiano.com/2008/10/28/pygments-textmate-bundle/
+.. _here: https://programmingzen.com/pygments-textmate-bundle/
Bash completion
---------------
diff --git a/doc/docs/java.rst b/doc/docs/java.rst
index f553463c..a8a5beb3 100644
--- a/doc/docs/java.rst
+++ b/doc/docs/java.rst
@@ -2,18 +2,18 @@
Use Pygments in Java
=====================
-Thanks to `Jython <http://www.jython.org>`_ it is possible to use Pygments in
+Thanks to `Jython <https://www.jython.org/>`_ it is possible to use Pygments in
Java.
This page is a simple tutorial to get an idea of how this works. You can
-then look at the `Jython documentation <http://www.jython.org/docs/>`_ for more
+then look at the `Jython documentation <https://jython.readthedocs.io/en/latest/>`_ for more
advanced uses.
Since version 1.5, Pygments is deployed on `Maven Central
-<http://repo1.maven.org/maven2/org/pygments/pygments/>`_ as a JAR, as is Jython
+<https://repo1.maven.org/maven2/org/pygments/pygments/>`_ as a JAR, as is Jython
which makes it a lot easier to create a Java project.
-Here is an example of a `Maven <http://www.maven.org>`_ ``pom.xml`` file for a
+Here is an example of a `Maven <https://maven.apache.org/>`_ ``pom.xml`` file for a
project running Pygments:
.. sourcecode:: xml
diff --git a/doc/docs/lexerdevelopment.rst b/doc/docs/lexerdevelopment.rst
index 530d8c15..c776457b 100644
--- a/doc/docs/lexerdevelopment.rst
+++ b/doc/docs/lexerdevelopment.rst
@@ -197,7 +197,7 @@ defined, it defaults to `re.MULTILINE`. For more information about regular
expression flags see the page about `regular expressions`_ in the Python
documentation.
-.. _regular expressions: http://docs.python.org/library/re.html#regular-expression-syntax
+.. _regular expressions: https://docs.python.org/library/re.html#regular-expression-syntax
Scanning multiple tokens at once
diff --git a/doc/docs/moinmoin.rst b/doc/docs/moinmoin.rst
index 8b2216b3..80ed25c3 100644
--- a/doc/docs/moinmoin.rst
+++ b/doc/docs/moinmoin.rst
@@ -36,4 +36,4 @@ If you do not want to do that and are willing to accept larger HTML output, you
can set the ``INLINESTYLES`` option to True.
-.. _Moin: http://moinmoin.wikiwikiweb.de/
+.. _Moin: https://moinmo.in/
diff --git a/doc/docs/plugins.rst b/doc/docs/plugins.rst
index a6f8d7b0..1008013a 100644
--- a/doc/docs/plugins.rst
+++ b/doc/docs/plugins.rst
@@ -7,7 +7,7 @@ use the lexer/formatter/style/filter lookup functions (`lexers.get_lexer_by_name
et al.), you can use `setuptools`_ entrypoints to add new lexers, formatters
or styles as if they were in the Pygments core.
-.. _setuptools: http://peak.telecommunity.com/DevCenter/setuptools
+.. _setuptools: https://pypi.org/project/setuptools/
That means you can use your highlighter modules with the `pygmentize` script,
which relies on the mentioned functions.
@@ -82,7 +82,7 @@ This documentation doesn't explain how to use those entrypoints because this is
covered in the `setuptools documentation`_. That page should cover everything
you need to write a plugin.
-.. _setuptools documentation: http://peak.telecommunity.com/DevCenter/setuptools
+.. _setuptools documentation: https://setuptools.readthedocs.io/en/latest/
Extending The Core
diff --git a/doc/docs/rstdirective.rst b/doc/docs/rstdirective.rst
index c0d503b3..edc117d3 100644
--- a/doc/docs/rstdirective.rst
+++ b/doc/docs/rstdirective.rst
@@ -19,4 +19,4 @@ From Pygments 0.9, the directive is shipped in the distribution as
``.. code::`` directives and highlights the contents in the specified language
if the `handlecodeblocks` option is true.
-.. _ReST: http://docutils.sf.net/rst.html
+.. _ReST: https://docutils.sourceforge.io/rst.html
diff --git a/doc/faq.rst b/doc/faq.rst
index 61d19856..c094d085 100644
--- a/doc/faq.rst
+++ b/doc/faq.rst
@@ -89,41 +89,41 @@ Who uses Pygments?
This is an (incomplete) list of projects and sites known to use the Pygments highlighter.
-* `Wikipedia <http://en.wikipedia.org>`_
-* `BitBucket <http://bitbucket.org/>`_, a Mercurial and Git hosting site
+* `Wikipedia <https://en.wikipedia.org/>`_
+* `BitBucket <https://bitbucket.org/>`_, a Mercurial and Git hosting site
* `The Sphinx documentation builder <https://sphinx-doc.org/>`_, for embedded source examples
-* `rst2pdf <http://code.google.com/p/rst2pdf/>`_, a reStructuredText to PDF converter
-* `Codecov <http://codecov.io/>`_, a code coverage CI service
-* `Trac <http://trac.edgewall.org/>`_, the universal project management tool
-* `AsciiDoc <http://www.methods.co.nz/asciidoc/>`_, a text-based documentation generator
-* `ActiveState Code <http://code.activestate.com/>`_, the Python Cookbook successor
+* `rst2pdf <https://github.com/ralsina/rst2pdf>`_, a reStructuredText to PDF converter
+* `Codecov <https://codecov.io/>`_, a code coverage CI service
+* `Trac <https://trac.edgewall.org/>`_, the universal project management tool
+* `AsciiDoc <https://www.methods.co.nz/asciidoc/>`_, a text-based documentation generator
+* `ActiveState Code <https://code.activestate.com/>`_, the Python Cookbook successor
* `ViewVC <http://viewvc.org/>`_, a web-based version control repository browser
-* `BzrFruit <http://repo.or.cz/w/bzrfruit.git>`_, a Bazaar branch viewer
+* `BzrFruit <https://repo.or.cz/w/bzrfruit.git>`_, a Bazaar branch viewer
* `QBzr <http://bazaar-vcs.org/QBzr>`_, a cross-platform Qt-based GUI front end for Bazaar
-* `Review Board <http://www.review-board.org/>`_, a collaborative code reviewing tool
-* `Diamanda <http://code.google.com/p/diamanda/>`_, a Django powered wiki system with support for Pygments
+* `Review Board <https://www.reviewboard.org/>`_, a collaborative code reviewing tool
+* `Diamanda <https://code.google.com/archive/p/diamanda/>`_, a Django powered wiki system with support for Pygments
* `Progopedia <http://progopedia.ru/>`_ (`English <http://progopedia.com/>`_),
an encyclopedia of programming languages
-* `Bruce <http://r1chardj0n3s.googlepages.com/bruce>`_, a reStructuredText presentation tool
+* `Bruce <https://sites.google.com/site/r1chardj0n3s/bruce>`_, a reStructuredText presentation tool
* `PIDA <http://pida.co.uk/>`_, a universal IDE written in Python
-* `BPython <http://www.noiseforfree.com/bpython/>`_, a curses-based intelligent Python shell
-* `PuDB <https://pypi.python.org/pypi/pudb>`_, a console Python debugger
-* `XWiki <http://www.xwiki.org/>`_, a wiki-based development framework in Java, using Jython
+* `BPython <https://bpython-interpreter.org/>`_, a curses-based intelligent Python shell
+* `PuDB <https://pypi.org/project/pudb/>`_, a console Python debugger
+* `XWiki <https://www.xwiki.org/>`_, a wiki-based development framework in Java, using Jython
* `roux <http://ananelson.com/software/roux/>`_, a script for running R scripts
and creating beautiful output including graphs
* `hurl <http://hurl.it/>`_, a web service for making HTTP requests
* `wxHTMLPygmentizer <http://colinbarnette.net/projects/wxHTMLPygmentizer>`_ is
a GUI utility, used to make code-colorization easier
-* `Postmarkup <http://code.google.com/p/postmarkup/>`_, a BBCode to XHTML generator
+* `Postmarkup <https://code.google.com/archive/p/postmarkup/>`_, a BBCode to XHTML generator
* `WpPygments <http://blog.mirotin.net/?page_id=49>`_, and `WPygments
<https://github.com/capynet/WPygments>`_, highlighter plugins for WordPress
* `Siafoo <http://siafoo.net>`_, a tool for sharing and storing useful code and programming experience
* `D source <http://www.dsource.org/>`_, a community for the D programming language
* `dpaste.com <http://dpaste.com/>`_, another Django pastebin
-* `Django snippets <http://www.djangosnippets.org/>`_, a pastebin for Django code
+* `Django snippets <https://djangosnippets.org/>`_, a pastebin for Django code
* `Fayaa <http://www.fayaa.com/code/>`_, a Chinese pastebin
* `Incollo.com <http://incollo.com>`_, a free collaborative debugging tool
-* `PasteBox <http://p.boxnet.eu/>`_, a pastebin focused on privacy
+* `PasteBox <https://p.boxnet.eu/>`_, a pastebin focused on privacy
* `hilite.me <http://www.hilite.me/>`_, a site to highlight code snippets
* `patx.me <http://patx.me/paste>`_, a pastebin
* `Fluidic <https://github.com/richsmith/fluidic>`_, an experiment in
diff --git a/doc/languages.rst b/doc/languages.rst
index 57bea8ea..5ef26e19 100644
--- a/doc/languages.rst
+++ b/doc/languages.rst
@@ -11,8 +11,8 @@ Programming languages
* ActionScript
* Ada
* Agda (incl. literate)
-* `Alloy <http://alloy.mit.edu>`_
-* `AMPL <http://ampl.com>`_
+* `Alloy <https://alloytools.org/>`_
+* `AMPL <https://ampl.com/>`_
* ANTLR
* APL
* AppleScript
@@ -24,13 +24,13 @@ Programming languages
* BBC Basic
* Befunge
* BlitzBasic
-* `Boa <http://boa.cs.iastate.edu/docs/index.php>`_
+* `Boa <https://boa.cs.iastate.edu/docs/>`_
* Boo
* `Boogie <https://boogie.codeplex.com/>`_
* BrainFuck
* C, C++ (incl. dialects like Arduino)
* C#
-* `Chapel <http://chapel.cray.com>`_
+* `Chapel <https://chapel-lang.org/>`_
* `Charm++ CI <http://charmplusplus.org/>`_
* Cirru
* Clay
@@ -61,19 +61,19 @@ Programming languages
* Fancy
* Fantom
* `Fennel <https://fennel-lang.org/>`_
-* `FloScript <http://ioflo.com/>`_
+* `FloScript <https://ioflo.com/>`_
* Fortran
* `FreeFEM++ <https://freefem.org/>`_
* F#
* GAP
* Gherkin (Cucumber)
* GLSL shaders
-* `Golo <http://golo-lang.org/>`_
+* `Golo <https://golo-lang.org/>`_
* Gosu
* Groovy
-* `Haskell <http://www.haskell.org>`_ (incl. Literate Haskell)
+* `Haskell <https://www.haskell.org/>`_ (incl. Literate Haskell)
* HLSL
-* `HSpec <http://hackage.haskell.org/package/hspec>`_
+* `HSpec <https://hackage.haskell.org/package/hspec>`_
* Hy
* IDL
* Idris (incl. Literate Idris)
@@ -106,7 +106,7 @@ Programming languages
* NesC
* NewLISP
* Nimrod
-* `Nit <http://nitlanguage.org>`_
+* `Nit <https://nitlanguage.org/>`_
* Notmuch
* NuSMV
* Objective-C
@@ -115,7 +115,7 @@ Programming languages
* OCaml
* Opa
* OpenCOBOL
-* `ParaSail <http://www.parasail-lang.org>`_
+* `ParaSail <https://www.parasail-lang.org/>`_
* Pawn
* PHP
* `Perl 5 <https://perl.org>`_
@@ -126,10 +126,10 @@ Programming languages
* PowerShell
* `Praat <http://www.praat.org>`_
* Prolog
-* `Python <https://python.org>`_ 2.x and 3.x (incl. console sessions and
+* `Python <https://python.org/>`_ 2.x and 3.x (incl. console sessions and
tracebacks)
* QBasic
-* `Racket <http://racket-lang.org/>`_
+* `Racket <https://racket-lang.org/>`_
* `Raku <https://www.raku.org/>`_ a.k.a. Perl 6
* `REBOL <http://www.rebol.com>`_
* `Red <https://www.red-lang.org>`_
@@ -151,7 +151,7 @@ Programming languages
* `Slurm <https://slurm.schedmd.com/overview.html>`_
* Smalltalk
* SNOBOL
-* `Snowball <http://snowballstem.org/>`_
+* `Snowball <https://snowballstem.org/>`_
* `Solidity <https://solidity.readthedocs.io/>`_
* SourcePawn
* `Stan <https://mc-stan.org/>`_
@@ -159,7 +159,7 @@ Programming languages
* Stata
* Swift
* Swig
-* `SuperCollider <http://supercollider.github.io/>`_
+* `SuperCollider <https://supercollider.github.io/>`_
* Tcl
* `Tera Term language <https://ttssh2.osdn.jp/>`_
* TypeScript
@@ -174,7 +174,7 @@ Programming languages
* Visual Basic.NET
* Visual FoxPro
* `Whiley <http://whiley.org/>`_
-* `Xtend <http://xtend-lang.org/>`_
+* `Xtend <https://www.eclipse.org/xtend/>`_
* XQuery
* `Zeek <https://www.zeek.org>`_
* Zephir
@@ -194,12 +194,12 @@ Template languages
* Handlebars
* JSP (Java Server Pages)
* Liquid
-* `Myghty <http://www.myghty.org>`_ (the HTML::Mason based framework)
+* `Myghty <https://pypi.org/project/Myghty/>`_ (the HTML::Mason based framework)
* `Mako <https://www.makotemplates.org>`_ (the Myghty successor)
* Slim
* `Smarty <https://www.smarty.net>`_ templates (PHP templating)
* Tea
-* `Twig <http://twig.sensiolabs.org/>`_
+* `Twig <https://twig.symfony.com/>`_
Other markup
------------
@@ -244,11 +244,11 @@ Other markup
* MySQL
* NCAR command language
* Nginx config files
-* `Nix language <http://nixos.org/nix/>`_
+* `Nix language <https://nixos.org/nix/>`_
* NSIS scripts
* Notmuch
* POV-Ray scenes
-* `Puppet <http://puppetlabs.com/>`_
+* `Puppet <https://puppet.com/>`_
* QML
* Ragel
* Redcode
diff --git a/external/rst-directive.py b/external/rst-directive.py
index e0c39b32..6f3173c4 100644
--- a/external/rst-directive.py
+++ b/external/rst-directive.py
@@ -27,9 +27,9 @@
Look at the `directive documentation`_ to get all the gory details.
- .. _Docutils: http://docutils.sf.net/
+ .. _Docutils: https://docutils.sourceforge.io/
.. _directive documentation:
- http://docutils.sourceforge.net/docs/howto/rst-directives.html
+ https://docutils.sourceforge.io/docs/howto/rst-directives.html
:copyright: Copyright 2006-2019 by the Pygments team, see AUTHORS.
:license: BSD, see LICENSE for details.
diff --git a/pygments/formatters/html.py b/pygments/formatters/html.py
index 042f04cf..be9d8534 100644
--- a/pygments/formatters/html.py
+++ b/pygments/formatters/html.py
@@ -61,7 +61,7 @@ def _get_ttype_class(ttype):
CSSFILE_TEMPLATE = '''\
/*
-generated by Pygments <http://pygments.org>
+generated by Pygments <https://pygments.org/>
Copyright 2006-2019 by the Pygments team.
Licensed under the BSD license, see LICENSE for details.
*/
@@ -75,7 +75,7 @@ DOC_HEADER = '''\
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01//EN"
"http://www.w3.org/TR/html4/strict.dtd">
<!--
-generated by Pygments <http://pygments.org>
+generated by Pygments <https://pygments.org/>
Copyright 2006-2019 by the Pygments team.
Licensed under the BSD license, see LICENSE for details.
-->
diff --git a/setup.py b/setup.py
index e72580b2..0c9f4f54 100755
--- a/setup.py
+++ b/setup.py
@@ -28,7 +28,7 @@ from pygments import __version__
setup(
name = 'Pygments',
version = __version__,
- url = 'http://pygments.org/',
+ url = 'https://pygments.org/',
license = 'BSD License',
author = 'Georg Brandl',
author_email = 'georg@python.org',