summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorOleh Prypin <oleh@pryp.in>2021-01-20 10:48:45 +0100
committerGitHub <noreply@github.com>2021-01-20 10:48:45 +0100
commit6f4309217326430145564ae8b1bb393ea684f39f (patch)
treebf4025a5e709426dc927c4afc4fd2286f8450ed9 /Makefile
parentf0445be718da83541ea3401aad882f3937147263 (diff)
downloadpygments-git-6f4309217326430145564ae8b1bb393ea684f39f.tar.gz
Also add auto-updatable output-based tests to examplefiles (#1689)
Co-authored-by: Georg Brandl <georg@python.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile13
1 files changed, 3 insertions, 10 deletions
diff --git a/Makefile b/Makefile
index be3e12a9..ab86244c 100644
--- a/Makefile
+++ b/Makefile
@@ -12,8 +12,8 @@ PYTHON ?= python3
export PYTHONPATH = $(shell echo "$$PYTHONPATH"):$(shell python -c 'import os; print ":".join(os.path.abspath(line.strip()) for line in file("PYTHONPATH"))' 2>/dev/null)
-.PHONY: all check clean clean-pyc codetags docs mapfiles \
- pylint reindent test test-coverage test-examplefiles \
+.PHONY: all check clean clean-pyc docs mapfiles \
+ pylint reindent test test-coverage \
tox-test tox-test-coverage regexlint
all: clean-pyc check test
@@ -26,16 +26,12 @@ check:
-i docs/build -i pygments/formatters/_mapping.py -i pygments/unistring.py
clean: clean-pyc
- -rm -rf doc/_build build Pygments.egg-info tests/examplefiles/output
+ -rm -rf doc/_build build Pygments.egg-info
-rm -f codetags.html
clean-pyc:
find . -name '__pycache__' -exec rm -rf {} +
-codetags:
- @$(PYTHON) scripts/find_codetags.py -i tests/examplefiles -i scripts/pylintrc \
- -i scripts/find_codetags.py -o codetags.html .
-
docs:
make -C doc html
@@ -57,9 +53,6 @@ test:
test-coverage:
@$(PYTHON) `which py.test` --cov --cov-report=html --cov-report=term $(TEST)
-test-examplefiles:
- @$(PYTHON) `which py.test` tests.test_examplefiles
-
tox-test:
@tox -- $(TEST)