summaryrefslogtreecommitdiff
path: root/pygments/formatter.py
diff options
context:
space:
mode:
authorGeorg Brandl <georg@python.org>2020-02-29 15:45:08 +0100
committerGitHub <noreply@github.com>2020-02-29 15:45:08 +0100
commit35544e2fc6eed0ce4a27ec7285aac71ff0ddc473 (patch)
tree4390507bf0d4d5a4596cfc57c575da12f9da40f9 /pygments/formatter.py
parent14fc057d300102d88a07eda5558f238d49dd23f6 (diff)
downloadpygments-git-35544e2fc6eed0ce4a27ec7285aac71ff0ddc473.tar.gz
Remove Python 2 compatibility (#1348)
* Remove Python 2 compatibility * remove 2/3 shims in pygments.util * update setup.py metadata * Remove unneeded object inheritance. * Remove unneeded future imports.
Diffstat (limited to 'pygments/formatter.py')
-rw-r--r--pygments/formatter.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/pygments/formatter.py b/pygments/formatter.py
index f09f6e3c..60531523 100644
--- a/pygments/formatter.py
+++ b/pygments/formatter.py
@@ -11,19 +11,19 @@
import codecs
-from pygments.util import get_bool_opt, string_types
+from pygments.util import get_bool_opt
from pygments.styles import get_style_by_name
__all__ = ['Formatter']
def _lookup_style(style):
- if isinstance(style, string_types):
+ if isinstance(style, str):
return get_style_by_name(style)
return style
-class Formatter(object):
+class Formatter:
"""
Converts a token stream to text.