summaryrefslogtreecommitdiff
path: root/scripts
diff options
context:
space:
mode:
authorGeorg Brandl <georg@python.org>2020-02-29 15:45:08 +0100
committerGitHub <noreply@github.com>2020-02-29 15:45:08 +0100
commit35544e2fc6eed0ce4a27ec7285aac71ff0ddc473 (patch)
tree4390507bf0d4d5a4596cfc57c575da12f9da40f9 /scripts
parent14fc057d300102d88a07eda5558f238d49dd23f6 (diff)
downloadpygments-git-35544e2fc6eed0ce4a27ec7285aac71ff0ddc473.tar.gz
Remove Python 2 compatibility (#1348)
* Remove Python 2 compatibility * remove 2/3 shims in pygments.util * update setup.py metadata * Remove unneeded object inheritance. * Remove unneeded future imports.
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/check_sources.py2
-rwxr-xr-xscripts/debug_lexer.py2
-rw-r--r--scripts/detect_missing_analyse_text.py1
-rw-r--r--scripts/get_vimkw.py2
-rwxr-xr-xscripts/vim2pygments.py4
5 files changed, 1 insertions, 10 deletions
diff --git a/scripts/check_sources.py b/scripts/check_sources.py
index b1f3bccf..57151192 100755
--- a/scripts/check_sources.py
+++ b/scripts/check_sources.py
@@ -11,8 +11,6 @@
:license: BSD, see LICENSE for details.
"""
-from __future__ import print_function
-
import io
import os
import re
diff --git a/scripts/debug_lexer.py b/scripts/debug_lexer.py
index ef01a23f..6963a5c0 100755
--- a/scripts/debug_lexer.py
+++ b/scripts/debug_lexer.py
@@ -12,8 +12,6 @@
:license: BSD, see LICENSE for details.
"""
-from __future__ import print_function
-
import os
import sys
diff --git a/scripts/detect_missing_analyse_text.py b/scripts/detect_missing_analyse_text.py
index ab58558e..e9383421 100644
--- a/scripts/detect_missing_analyse_text.py
+++ b/scripts/detect_missing_analyse_text.py
@@ -1,4 +1,3 @@
-from __future__ import print_function
import sys
from pygments.lexers import get_all_lexers, find_lexer_class
diff --git a/scripts/get_vimkw.py b/scripts/get_vimkw.py
index a1b6873e..eecbc43f 100644
--- a/scripts/get_vimkw.py
+++ b/scripts/get_vimkw.py
@@ -1,5 +1,3 @@
-from __future__ import print_function
-
import re
from pygments.util import format_lines
diff --git a/scripts/vim2pygments.py b/scripts/vim2pygments.py
index 42af0bbe..50d69bc6 100755
--- a/scripts/vim2pygments.py
+++ b/scripts/vim2pygments.py
@@ -11,8 +11,6 @@
:license: BSD, see LICENSE for details.
"""
-from __future__ import print_function
-
import sys
import re
from os import path
@@ -863,7 +861,7 @@ def find_colors(code):
return default_token, color_map
-class StyleWriter(object):
+class StyleWriter:
def __init__(self, code, name):
self.code = code