summaryrefslogtreecommitdiff
path: root/scripts
diff options
context:
space:
mode:
authorJean Abou-Samra <jean@abou-samra.fr>2023-02-23 13:44:22 +0100
committerGitHub <noreply@github.com>2023-02-23 13:44:22 +0100
commite589fee754a76e9600dcb42baaeb3372d9e163d7 (patch)
tree34a4a1bef36b0d1b65b8925e9751a9ee3bdc7281 /scripts
parent1e85f7c2ad2edfeae7f0c566163931324f64f949 (diff)
downloadpygments-git-e589fee754a76e9600dcb42baaeb3372d9e163d7.tar.gz
Replace Makefile with tox (#2331)
Porting notes: - tox handles Python environments automatically. Remove a bit of PYTHONPATH manipulation (that was using Python 2 code which always failed!) - No `clean` target: `git clean -xdf` should fit the bill. - No `reindent` target: the `reindent.py` script it was using does not exist (anymore?). - No equivalent of tox-test-coverage, which was an artifact of the past, using nose. Instead, the test-coverage target only is ported, which uses pytest, and works.
Diffstat (limited to 'scripts')
-rw-r--r--scripts/gen_mapfiles.py2
-rw-r--r--scripts/release-checklist9
2 files changed, 6 insertions, 5 deletions
diff --git a/scripts/gen_mapfiles.py b/scripts/gen_mapfiles.py
index 0b2f2e9c..bb434e11 100644
--- a/scripts/gen_mapfiles.py
+++ b/scripts/gen_mapfiles.py
@@ -39,7 +39,7 @@ def main():
lines.sort()
new_dict = '\n'.join(lines)
content = f'''# Automatically generated by scripts/gen_mapfiles.py.
-# DO NOT EDIT BY HAND; run `make mapfiles` instead.
+# DO NOT EDIT BY HAND; run `tox -e mapfiles` instead.
{key.upper()} = {{
{new_dict}
diff --git a/scripts/release-checklist b/scripts/release-checklist
index 539933f7..462250f1 100644
--- a/scripts/release-checklist
+++ b/scripts/release-checklist
@@ -2,17 +2,18 @@ Release checklist
=================
* Check ``git status``
-* ``make check``
-* LATER when configured properly: ``make pylint``
* ``tox``
+* ``tox -e check``
+* LATER when configured properly: ``tox -e pylint``
* Update version in ``pygments/__init__.py``
* Check pyproject.toml metadata: long description, trove classifiers
* Update release date/code name in ``CHANGES``
* ``git commit``
* Wait for the CI to finish
-* ``make clean``
+* ``git clean -xdf`` (warning: removes all untracked and ignored files,
+ do a dry run with ``git clean -xdfn`` first)
* ``python3 -m build``
-* Check the size of the generated packages. If they're significantly different from the last release, check if the repository is in a modified state and that ``make clean`` was run.
+* Check the size of the generated packages. If they're significantly different from the last release, check if the repository is in a modified state and that ``git clean`` was run.
* ``twine upload dist/Pygments-$NEWVER*``
* Check PyPI release page for obvious errors (like different file sizes!)
* ``git tag -a``