summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.github/workflows/build.yaml4
-rw-r--r--Makefile4
-rw-r--r--setup.cfg1
-rw-r--r--tox.ini4
4 files changed, 7 insertions, 6 deletions
diff --git a/.github/workflows/build.yaml b/.github/workflows/build.yaml
index ca254229..a598a0cc 100644
--- a/.github/workflows/build.yaml
+++ b/.github/workflows/build.yaml
@@ -8,7 +8,7 @@ jobs:
strategy:
matrix:
os: [ubuntu-latest, windows-latest]
- python-version: [3.5, 3.6, 3.7, 3.8, 3.9, pypy3]
+ python-version: ["3.5", "3.6", "3.7", "3.8", "3.9", "3.10", "pypy3"]
max-parallel: 4
steps:
@@ -26,7 +26,7 @@ jobs:
run: make test TEST=-v
if: runner.os == 'Linux'
- name: Test package
- run: py.test
+ run: pytest
if: runner.os == 'Windows' && ! contains(matrix['python-version'], 'pypy')
check:
diff --git a/Makefile b/Makefile
index 1e75e37c..404bd6d4 100644
--- a/Makefile
+++ b/Makefile
@@ -51,10 +51,10 @@ reindent:
TEST = tests
test:
- @$(PYTHON) `which py.test` $(TEST)
+ @$(PYTHON) `which pytest` $(TEST)
test-coverage:
- @$(PYTHON) `which py.test` --cov --cov-report=html --cov-report=term $(TEST)
+ @$(PYTHON) `which pytest` --cov --cov-report=html --cov-report=term $(TEST)
tox-test:
@tox -- $(TEST)
diff --git a/setup.cfg b/setup.cfg
index c5387c1d..6c48160b 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -23,6 +23,7 @@ classifiers =
Programming Language :: Python :: 3.7
Programming Language :: Python :: 3.8
Programming Language :: Python :: 3.9
+ Programming Language :: Python :: 3.10
Programming Language :: Python :: Implementation :: CPython
Programming Language :: Python :: Implementation :: PyPy
Topic :: Text Processing :: Filters
diff --git a/tox.ini b/tox.ini
index c45493d1..aa26979c 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,11 +1,11 @@
[tox]
-envlist = py35, py36, py37, py38, py39, pypy3, lint
+envlist = py35, py36, py37, py38, py39, py310, pypy3, lint
[testenv]
deps =
pytest
pytest-cov
-commands = py.test {posargs}
+commands = pytest {posargs}
[testenv:lint]