diff options
author | gbrandl <devnull@localhost> | 2007-02-12 23:38:46 +0100 |
---|---|---|
committer | gbrandl <devnull@localhost> | 2007-02-12 23:38:46 +0100 |
commit | 8ac95bf314343f8db0ec8123296b60aefda8b02f (patch) | |
tree | 7813371046f03132d690b8556c857fc453e6c9b6 /Makefile | |
parent | 16b1f0bb0fbc6ea7aab974cb220406632de4c7c0 (diff) | |
download | pygments-8ac95bf314343f8db0ec8123296b60aefda8b02f.tar.gz |
[svn] Quite a few things:
- new pygmentize options, -F for filters and -H for detail help.
- an automatically-created formatter map
- better HTML formatter subclassing
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 7 |
1 files changed, 4 insertions, 3 deletions
@@ -12,7 +12,7 @@ PYTHON ?= python export PYTHONPATH = $(shell echo "$$PYTHONPATH"):$(shell python -c 'print ":".join(line.strip() for line in file("PYTHONPATH"))' 2>/dev/null) -.PHONY: all apidocs check clean clean-pyc codetags docs epydoc lexermap \ +.PHONY: all apidocs check clean clean-pyc codetags docs epydoc mapfiles \ pylint reindent test all: clean-pyc check test @@ -56,8 +56,9 @@ epydoc: apidocs/*.html @$(PYTHON) scripts/fix_epydoc_markup.py apidocs -lexermap: - cd pygments/lexers; $(PYTHON) _mapping.py +mapfiles: + (cd pygments/lexers; $(PYTHON) _mapping.py) + (cd pygments/formatters; $(PYTHON) _mapping.py) pylint: @pylint --rcfile scripts/pylintrc pygments |