summaryrefslogtreecommitdiff
path: root/pygments/lexers/shell.py
diff options
context:
space:
mode:
authorGeorg Brandl <georg@python.org>2016-02-02 12:16:36 +0100
committerGeorg Brandl <georg@python.org>2016-02-02 12:16:36 +0100
commitdd0b82c562034edbe6f9d413a742a856ac4a1f89 (patch)
tree29bf948b943fdbbefcbf75a9756168d2cfd73ccd /pygments/lexers/shell.py
parent18b6f332c94424e4e3f659cbbb0e04801ae59e66 (diff)
downloadpygments-dd0b82c562034edbe6f9d413a742a856ac4a1f89.tar.gz
Add support for highlighting the exheres-0 format
From: "Wulf C. Krueger" <philantrop@exherbo.org>
Diffstat (limited to 'pygments/lexers/shell.py')
-rw-r--r--pygments/lexers/shell.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/pygments/lexers/shell.py b/pygments/lexers/shell.py
index dc23d018..4145939e 100644
--- a/pygments/lexers/shell.py
+++ b/pygments/lexers/shell.py
@@ -35,6 +35,7 @@ class BashLexer(RegexLexer):
name = 'Bash'
aliases = ['bash', 'sh', 'ksh', 'shell']
filenames = ['*.sh', '*.ksh', '*.bash', '*.ebuild', '*.eclass',
+ '*.exheres-0', '*.exlib',
'.bashrc', 'bashrc', '.bash_*', 'bash_*', 'PKGBUILD']
mimetypes = ['application/x-sh', 'application/x-shellscript']