summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorgbrandl <devnull@localhost>2006-10-30 11:29:34 +0100
committergbrandl <devnull@localhost>2006-10-30 11:29:34 +0100
commit02297b97d1d2aa9ef686e4e33446a87dcb47c856 (patch)
tree5de674ce3ad24c8d279e5bbdb8934b20355807f2 /setup.py
parent5555cc89b14f0d30438d04eb535ca8c61fa6bd8a (diff)
downloadpygments-02297b97d1d2aa9ef686e4e33446a87dcb47c856.tar.gz
[svn] Release preparation.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py10
1 files changed, 8 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 130c40f6..b8fdbee6 100644
--- a/setup.py
+++ b/setup.py
@@ -5,12 +5,18 @@ from setuptools import setup, find_packages
import pygments
+# PY24: use .rsplit
+index = pygments.__author__.rindex(' ')
+author, email = pygments.__author__[:index], pygments.__author__[index+1:]
+email = email[1:-1]
+
setup(
name = 'Pygments',
version = pygments.__version__,
url = pygments.__url__,
license = pygments.__license__,
- author = pygments.__author__,
+ author = author,
+ author_email = email,
description = 'Pygments is a syntax highlighting package written in Python.',
long_description = pygments.__doc__,
keywords = 'syntax highlighting',
@@ -20,7 +26,7 @@ setup(
zip_safe = False,
include_package_data = True,
classifiers = [
- 'License :: OSI Approved :: GNU Lesser General Public License (LGPL)',
+ 'License :: OSI Approved :: GNU Library or Lesser General Public License (LGPL)',
'Intended Audience :: Developers',
'Intended Audience :: End Users/Desktop',
'Intended Audience :: System Administrators',