summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorgbrandl <devnull@localhost>2007-06-09 16:04:52 +0200
committergbrandl <devnull@localhost>2007-06-09 16:04:52 +0200
commit260c5b140d3f0d2d0424f04e12c81a6ee1647573 (patch)
treea50d7bb3125ae4c85b033b015b8dd83588c22b59 /setup.py
parent2d7c675cae94a51f19c44cff1a4b58bbe1693839 (diff)
downloadpygments-260c5b140d3f0d2d0424f04e12c81a6ee1647573.tar.gz
[svn] Better author extraction in setup.py.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 1 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index da572d5d..037f94bf 100644
--- a/setup.py
+++ b/setup.py
@@ -6,10 +6,7 @@ from setuptools import setup, find_packages
import pygments
-# PY24: use .rsplit
-index = pygments.__author__.rindex(' ')
-author, email = pygments.__author__[:index], pygments.__author__[index+1:]
-email = email[1:-1]
+author, email = pygments.__author__[:-1].split(' <')
setup(
name = 'Pygments',