summaryrefslogtreecommitdiff
path: root/tests/run.py
diff options
context:
space:
mode:
authorGeorg Brandl <georg@python.org>2014-01-18 13:25:15 +0100
committerGeorg Brandl <georg@python.org>2014-01-18 13:25:15 +0100
commita9169c157a05c82a1b8a7ffb92e7f159fb4ca0f8 (patch)
treeface5db25ebef227315a0ae1080d4b2262f6fe23 /tests/run.py
parente921fe0b430608cb7e0c89f7fada9260cb4822eb (diff)
downloadpygments-a9169c157a05c82a1b8a7ffb92e7f159fb4ca0f8.tar.gz
futurizing: move to print_function and "except X as Y" syntax
Diffstat (limited to 'tests/run.py')
-rw-r--r--tests/run.py9
1 files changed, 5 insertions, 4 deletions
diff --git a/tests/run.py b/tests/run.py
index 6c22fdc8..f035fd56 100644
--- a/tests/run.py
+++ b/tests/run.py
@@ -11,6 +11,7 @@
:copyright: Copyright 2006-2014 by the Pygments team, see AUTHORS.
:license: BSD, see LICENSE for details.
"""
+from __future__ import print_function
import sys, os
@@ -40,14 +41,14 @@ try:
sys.path.insert(0, '..')
import pygments
except SyntaxError:
- print ('Syntax error: %s' % sys.exc_info()[1])
+ print(('Syntax error: %s' % sys.exc_info()[1]))
print ('Please run setup.py build before make test on Python 3')
sys.exit(1)
except ImportError:
- print ('Cannot find Pygments to test: %s' % sys.exc_info()[1])
+ print(('Cannot find Pygments to test: %s' % sys.exc_info()[1]))
sys.exit(1)
else:
- print ('Pygments %s test suite running (Python %s)...' %
- (pygments.__version__, sys.version.split()[0]))
+ print(('Pygments %s test suite running (Python %s)...' %
+ (pygments.__version__, sys.version.split()[0])))
nose.main()