summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Adams <mark@markadams.me>2015-10-23 18:58:59 -0500
committerMark Adams <madams@atlassian.com>2016-10-24 13:33:56 -0500
commit5c5fab1282c21a4a37dfebae54b2d4bc1ea7f037 (patch)
tree13454581d11246924b943be6b557b6b4c7ecd276
parent0d0d10c0e3d85d868a91815b6e88b0ee122998c6 (diff)
downloadpyjwt-fix-cli-script.tar.gz
Renamed jwt CLI script to jwt-cli to avoid issues with jwt script overlapping with the jwt package. Fixes #130fix-cli-script
-rw-r--r--CHANGELOG.md9
-rw-r--r--jwt/__main__.py2
-rwxr-xr-xsetup.py2
3 files changed, 10 insertions, 3 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index de4b14d..b5c398e 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -4,6 +4,13 @@ Change Log
All notable changes to this project will be documented in this file.
This project adheres to [Semantic Versioning](http://semver.org/).
+[Unreleased][unreleased]
+-------------------------------------------------------------------------
+### Changed
+- Renamed commandline script `jwt` to `jwt-cli` to avoid issues with the script clobbering the `jwt` module in some circumstances.
+
+### Fixed
+
[v1.4.2][1.4.2]
-------------------------------------------------------------------------
### Fixed
@@ -89,7 +96,7 @@ rarely used. Users affected by this should upgrade to 3.3+.
- Fixed a security vulnerability by adding support for a whitelist of allowed `alg` values `jwt.decode(algorithms=[])`. [#110][110]
-[unreleased]: https://github.com/jpadilla/pyjwt/compare/1.3.0...HEAD
+[unreleased]: https://github.com/jpadilla/pyjwt/compare/1.4.2...HEAD
[1.0.0]: https://github.com/jpadilla/pyjwt/compare/0.4.3...1.0.0
[1.0.1]: https://github.com/jpadilla/pyjwt/compare/1.0.0...1.0.1
[1.0.1]: https://github.com/jpadilla/pyjwt/compare/1.0.0...1.0.1
diff --git a/jwt/__main__.py b/jwt/__main__.py
index fffe212..94abf2a 100644
--- a/jwt/__main__.py
+++ b/jwt/__main__.py
@@ -31,7 +31,7 @@ The exp key is special and can take an offset to current Unix time.\
'''
p = optparse.OptionParser(
usage=usage,
- prog=__package__,
+ prog='pyjwt',
version='%s %s' % (__package__, __version__),
)
diff --git a/setup.py b/setup.py
index 00fb2a1..3a98f53 100755
--- a/setup.py
+++ b/setup.py
@@ -78,7 +78,7 @@ setup(
),
entry_points={
'console_scripts': [
- 'jwt = jwt.__main__:main'
+ 'pyjwt = jwt.__main__:main'
]
}
)