summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Adams <mark@markadams.me>2017-04-19 11:43:06 -0500
committerMark Adams <mark@markadams.me>2017-04-19 11:43:06 -0500
commitd2edca94839e4d58ab6619a109a1d5c7cc560366 (patch)
treecde9aa363a7dc9b6b80f213edd81d545331da3ec
parent908ee84aeefb8126a94e48e88ba9916d9d2512b3 (diff)
downloadpyjwt-madams/test.tar.gz
-rw-r--r--README.rst56
1 files changed, 0 insertions, 56 deletions
diff --git a/README.rst b/README.rst
deleted file mode 100644
index 5d2a8ee..0000000
--- a/README.rst
+++ /dev/null
@@ -1,56 +0,0 @@
-PyJWT
-=====
-
-.. image:: https://secure.travis-ci.org/jpadilla/pyjwt.svg?branch=master
- :target: http://travis-ci.org/jpadilla/pyjwt?branch=master
-
-.. image:: https://ci.appveyor.com/api/projects/status/h8nt70aqtwhht39t?svg=true
- :target: https://ci.appveyor.com/project/jpadilla/pyjwt
-
-.. image:: https://img.shields.io/pypi/v/pyjwt.svg
- :target: https://pypi.python.org/pypi/pyjwt
-
-.. image:: https://coveralls.io/repos/jpadilla/pyjwt/badge.svg?branch=master
- :target: https://coveralls.io/r/jpadilla/pyjwt?branch=master
-
-.. image:: https://readthedocs.org/projects/pyjwt/badge/?version=latest
- :target: https://pyjwt.readthedocs.io
-
-A Python implementation of `RFC
-7519 <https://tools.ietf.org/html/rfc7519>`_. Original implementation
-was written by `@progrium <https://github.com/progrium>`_.
-
-Installing
-----------
-
-Install with **pip**:
-
-.. code-block:: sh
-
- $ pip install PyJWT
-
-Usage
------
-
-.. code:: python
-
- >>> import jwt
- >>> encoded = jwt.encode({'some': 'payload'}, 'secret', algorithm='HS256')
- 'eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJzb21lIjoicGF5bG9hZCJ9.4twFt5NiznN84AWoo1d7KO1T_yoc0Z6XOpOVswacPZg'
-
- >>> jwt.decode(encoded, 'secret', algorithms=['HS256'])
- {'some': 'payload'}
-
-Documentation
--------------
-
-View the full docs online at https://pyjwt.readthedocs.io/en/latest/
-
-Tests
------
-
-You can run tests from the project root after cloning with:
-
-.. code-block:: sh
-
- $ python setup.py test