summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAsif Saif Uddin <auvipy@gmail.com>2022-05-30 16:26:29 +0600
committerGitHub <noreply@github.com>2022-05-30 16:26:29 +0600
commit08be27dfd2cd81c4846204f6507d082ffcbc0159 (patch)
tree04ca93096d0e14397feaabb138c87b6f39a277d4
parentb2f2079e6eeaf1a0f3b4244084ec7b8b6f8b05ec (diff)
parent8215bf8fd64db41fd7f4972fba905c4274a3e81c (diff)
downloadpyjwt-py36.tar.gz
Merge branch 'master' into py36py36
-rw-r--r--.github/workflows/main.yml4
-rw-r--r--pyproject.toml2
-rw-r--r--tests/test_api_jws.py4
-rw-r--r--tox.ini5
4 files changed, 10 insertions, 5 deletions
diff --git a/.github/workflows/main.yml b/.github/workflows/main.yml
index afb520c..4af2e2c 100644
--- a/.github/workflows/main.yml
+++ b/.github/workflows/main.yml
@@ -18,7 +18,9 @@ jobs:
strategy:
matrix:
platform: ["ubuntu-latest", "windows-latest"]
- python-version: ["3.7", "3.8", "3.9", "3.10"]
+
+ python-version: ["3.7", "3.8", "3.9", "3.10",
+ "3.11.0-beta - 3.11", "pypy-3.8", "pypy-3.9"]
steps:
- uses: "actions/checkout@v3"
diff --git a/pyproject.toml b/pyproject.toml
index 85e9eca..8c870eb 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,5 +1,5 @@
[build-system]
-requires = ["setuptools", "wheel"]
+requires = ["setuptools"]
build-backend = "setuptools.build_meta"
diff --git a/tests/test_api_jws.py b/tests/test_api_jws.py
index 0a0e295..23975fa 100644
--- a/tests/test_api_jws.py
+++ b/tests/test_api_jws.py
@@ -83,7 +83,7 @@ class TestJWS:
def test_options_must_be_dict(self, jws):
pytest.raises(TypeError, PyJWS, options=object())
- pytest.raises(TypeError, PyJWS, options=("something"))
+ pytest.raises((TypeError, ValueError), PyJWS, options=("something"))
def test_encode_decode(self, jws, payload):
secret = "secret"
@@ -607,7 +607,7 @@ class TestJWS:
with pytest.raises(TypeError):
jws.decode(token, "secret", options=object())
- with pytest.raises(TypeError):
+ with pytest.raises((TypeError, ValueError)):
jws.decode(token, "secret", options="something")
def test_custom_json_encoder(self, jws, payload):
diff --git a/tox.ini b/tox.ini
index d366461..74fff6a 100644
--- a/tox.ini
+++ b/tox.ini
@@ -13,13 +13,16 @@ python =
3.8: py38, typing
3.9: py39
3.10: py310
+ 3.11: py311
+ pypy-3.8: pypy3
+ pypy-3.9: pypy3
[tox]
envlist =
lint
typing
- py{36,37,38,39}-{crypto,nocrypto}
+ py{36,37,38,39,310,311,py3}-{crypto,nocrypto}
docs
pypi-description
coverage-report