summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-26 09:44:14 +0200
committerGitHub <noreply@github.com>2022-05-26 13:44:14 +0600
commit59065fa04d7d255f4a6452707af34fc9e4420d4d (patch)
tree7b5da8278b70f71272e2ca3bdcdc4168f6a5d3e5
parent9d4c06e07f6fb67f5fa486879c291018deb462e9 (diff)
downloadpyjwt-59065fa04d7d255f4a6452707af34fc9e4420d4d.tar.gz
Remove redundant wheel dep from pyproject.toml (#765)
The `wheel` dependency is added automatically by setuptools build backend (since day one) and therefore should not be specified explicitly. Listing it in documentation was a historical mistake and has been corrected since. See: https://github.com/pypa/setuptools/commit/f7d30a9529378cf69054b5176249e5457aaf640a
-rw-r--r--pyproject.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 85e9eca..8c870eb 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,5 +1,5 @@
[build-system]
-requires = ["setuptools", "wheel"]
+requires = ["setuptools"]
build-backend = "setuptools.build_meta"