summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorViicos <65306057+Viicos@users.noreply.github.com>2023-04-16 09:51:09 +0200
committerGitHub <noreply@github.com>2023-04-16 13:51:09 +0600
commit56b3d5633160e79e1f4c5c09023d68759cbf84a6 (patch)
tree8daa4bef8877eb6dcbb742bb0f63842ca70a51e6 /pyproject.toml
parentba726444a6cee75af59feb8ea08294d0ac89bedb (diff)
downloadpyjwt-56b3d5633160e79e1f4c5c09023d68759cbf84a6.tar.gz
Add complete types to take all allowed keys into account (#873)
* Use new style typing * Fix type annotations to allow all keys * Use string type annotations where required * [pre-commit.ci] auto fixes from pre-commit.com hooks for more information, see https://pre-commit.ci * Remove outdated comment * Ignore `if TYPE_CHECKING:` lines in coverage * Remove duplicate test * Fix mypy errors * Update algorithms.py * [pre-commit.ci] auto fixes from pre-commit.com hooks for more information, see https://pre-commit.ci * Fully switch to modern annotations * [pre-commit.ci] auto fixes from pre-commit.com hooks for more information, see https://pre-commit.ci * Update `pre-commit` mypy config * Use Python 3.11 for mypy * Update mypy Python version in `pyproject.toml` * Few tests mypy fixes * fix mypy errors on tests * Fix key imports * Remove unused import * Fix randomly failing test --------- Co-authored-by: pre-commit-ci[bot] <66853113+pre-commit-ci[bot]@users.noreply.github.com> Co-authored-by: Asif Saif Uddin <auvipy@gmail.com>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index e7920ff..40dfb7b 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -12,6 +12,7 @@ source = ["jwt", ".tox/*/site-packages"]
[tool.coverage.report]
show_missing = true
+exclude_lines = ["if TYPE_CHECKING:"]
[tool.isort]
profile = "black"
@@ -19,7 +20,7 @@ atomic = true
combine_as_imports = true
[tool.mypy]
-python_version = 3.7
+python_version = 3.11
ignore_missing_imports = true
warn_unused_ignores = true
no_implicit_optional = true