summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorJon Dufresne <jon.dufresne@gmail.com>2020-12-21 08:30:48 -0800
committerGitHub <noreply@github.com>2020-12-21 11:30:48 -0500
commit811ae79ceaae8ad9bbad24c30e2d3dd4d920e4df (patch)
tree0615c3a362bdf3bae25c10831e30787626e6061a /pyproject.toml
parentd5eff6452d66d0cafce9fecd19f5453ce8ea95fc (diff)
downloadpyjwt-811ae79ceaae8ad9bbad24c30e2d3dd4d920e4df.tar.gz
Simplify black configuration to be closer to upstream defaults (#568)
* Simplify black configuration to be closer to upstream defaults Avoid extra configuration by simply going with Black defaults. This allows removing some configuration options, thus simplifying the overall configuration. It also makes the code style closer to community conventions. As more projects adopt black formatting, more code will look like the black defaults. Further, the default 88 tends to create more readable lines, IMO. The black rationale is located at: https://black.readthedocs.io/en/stable/the_black_code_style.html#line-length * Update tests/test_api_jws.py Co-authored-by: José Padilla <jpadilla@webapplicate.com> * [pre-commit.ci] auto fixes from pre-commit.com hooks for more information, see https://pre-commit.ci * Update tests/test_api_jws.py * [pre-commit.ci] auto fixes from pre-commit.com hooks for more information, see https://pre-commit.ci Co-authored-by: José Padilla <jpadilla@webapplicate.com> Co-authored-by: pre-commit-ci[bot] <66853113+pre-commit-ci[bot]@users.noreply.github.com>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml5
1 files changed, 0 insertions, 5 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 95cc31b..85e9eca 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -15,12 +15,7 @@ source = ["jwt", ".tox/*/site-packages"]
show_missing = true
-[tool.black]
-line-length = 79
-
-
[tool.isort]
profile = "black"
atomic = true
combine_as_imports = true
-line_length = 79