summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJon Dufresne <jon.dufresne@gmail.com>2019-10-06 16:09:34 -0700
committerJosé Padilla <jpadilla@webapplicate.com>2019-10-06 19:09:34 -0400
commit3a20892442b34c754b26550e05f7f856fb008c94 (patch)
tree5f1122626b9e1f91632995e49011cf9b7c5280c7 /setup.py
parent1256a68de68464b3ae606f0ec2c03601ab1ea25c (diff)
downloadpyjwt-3a20892442b34c754b26550e05f7f856fb008c94.tar.gz
Remove setup.py test command in favor of pytest and tox (#442)
Using pytest and tox directly is simpler and more conventional then going through setup.py. Using setup.py installs packages as eggs where as tox uses the more typical pip. Overall simplifies setup.py. Fixes #415
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py17
1 files changed, 4 insertions, 13 deletions
diff --git a/setup.py b/setup.py
index 9ece6dc..1231235 100755
--- a/setup.py
+++ b/setup.py
@@ -32,15 +32,6 @@ if sys.argv[-1] == 'publish':
print(' git push --tags')
sys.exit()
-tests_require = [
- 'pytest>=4.0.1,<5.0.0',
- 'pytest-cov>=2.6.0,<3.0.0',
- 'pytest-runner>=4.2,<5.0.0',
-]
-
-needs_pytest = set(('pytest', 'test', 'ptr')).intersection(sys.argv)
-pytest_runner = ['pytest-runner'] if needs_pytest else []
-
setup(
name='PyJWT',
version=version,
@@ -68,11 +59,11 @@ setup(
'Topic :: Utilities',
],
python_requires=">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*",
- test_suite='tests',
- setup_requires=pytest_runner,
- tests_require=tests_require,
extras_require=dict(
- test=tests_require,
+ test=[
+ 'pytest>=4.0.1,<5.0.0',
+ 'pytest-cov>=2.6.0,<3.0.0',
+ ],
crypto=['cryptography >= 1.4'],
flake8=[
'flake8',