summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--AUTHORS12
-rw-r--r--LICENSE22
-rw-r--r--README.md17
-rwxr-xr-xsetup.py6
-rw-r--r--tox.ini2
5 files changed, 45 insertions, 14 deletions
diff --git a/AUTHORS b/AUTHORS
index e0636ed..be65bf8 100644
--- a/AUTHORS
+++ b/AUTHORS
@@ -1,15 +1,21 @@
-PyJWT lead developers
+PyJWT lead developer
---------------------
- - progrium <progrium@gmail.com>
- jpadilla <hello@jpadilla.com>
+
+Original author
+------------------
+
+- progrium <progrium@gmail.com>
+
+
Patches and Suggestions
-----------------------
- Boris Feld <boris.feld@novapost.fr> <lothiraldan@gmail.com>
- - Åsmund Ødegård <asmund@xal.no> <ao@mcash.no>
+ - Åsmund Ødegård <asmund@xal.no> <ao@mcash.no>
Adding support for RSA-SHA256 privat/public signature.
- Mark Adams <mark@markadams.me>
diff --git a/LICENSE b/LICENSE
index 927c375..bdc7819 100644
--- a/LICENSE
+++ b/LICENSE
@@ -1,7 +1,21 @@
-Copyright (c) 2011 Jeff Lindsay
+The MIT License (MIT)
-Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:
+Copyright (c) 2015 José Padilla
-The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/README.md b/README.md
index c596215..5886a37 100644
--- a/README.md
+++ b/README.md
@@ -1,6 +1,9 @@
-# PyJWT [![Build Status](https://travis-ci.org/progrium/pyjwt.png?branch=master)](https://travis-ci.org/progrium/pyjwt)
+# PyJWT
-A Python implementation of [JSON Web Token draft 01](http://self-issued.info/docs/draft-jones-json-web-token-01.html).
+[![build-status-image]][travis]
+[![pypi-version]][pypi]
+
+A Python implementation of [JSON Web Token draft 01][jwt-draft-01] originally written by [@progrium][progrium].
## Installing
@@ -102,7 +105,7 @@ used. PyJWT supports these reserved claim names:
### Expiration Time Claim
-From [draft 01 of the JWT spec](http://self-issued.info/docs/draft-jones-json-web-token-01.html#ReservedClaimName):
+From [draft 01 of the JWT spec][reserved-claimname]:
> The exp (expiration time) claim identifies the expiration time on or after
> which the JWT MUST NOT be accepted for processing. The processing of the exp
@@ -223,3 +226,11 @@ If the audience claim is incorrect, `jwt.InvalidAudienceError` will be raised.
## License
MIT
+
+[build-status-image]: https://secure.travis-ci.org/jpadilla/pyjwt.png?branch=master
+[travis]: http://travis-ci.org/jpadilla/pyjwt?branch=master
+[pypi-version]: https://pypip.in/version/pyjwt/badge.svg
+[pypi]: https://pypi.python.org/pypi/pyjwt
+[jwt-draft-01]: http://self-issued.info/docs/draft-jones-json-web-token-01.html
+[progrium]: https://github.com/progrium
+[reserved-claimname]: http://self-issued.info/docs/draft-jones-json-web-token-01.html#ReservedClaimName
diff --git a/setup.py b/setup.py
index 13fc3bd..b0d68c4 100755
--- a/setup.py
+++ b/setup.py
@@ -31,12 +31,12 @@ if sys.argv[-1] == 'publish':
setup(
name='PyJWT',
version=version,
- author='Jeff Lindsay',
- author_email='progrium@gmail.com',
+ author='José Padilla',
+ author_email='hello@jpadilla.com',
description='JSON Web Token implementation in Python',
license='MIT',
keywords='jwt json web token security signing',
- url='http://github.com/progrium/pyjwt',
+ url='http://github.com/jpadilla/pyjwt',
packages=['jwt'],
scripts=['bin/jwt'],
long_description=long_description,
diff --git a/tox.ini b/tox.ini
index 2c650a2..a1cdd0a 100644
--- a/tox.ini
+++ b/tox.ini
@@ -2,7 +2,7 @@
envlist = py26, py27, py32, py33, py34
[testenv]
+commands = {envpython} setup.py test
deps =
cryptography
unittest2
-commands = {envpython} setup.py test