summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml8
1 files changed, 6 insertions, 2 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 8c870eb..f406505 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -2,7 +2,6 @@
requires = ["setuptools"]
build-backend = "setuptools.build_meta"
-
[tool.coverage.run]
parallel = true
branch = true
@@ -14,8 +13,13 @@ source = ["jwt", ".tox/*/site-packages"]
[tool.coverage.report]
show_missing = true
-
[tool.isort]
profile = "black"
atomic = true
combine_as_imports = true
+
+[tool.mypy]
+python_version = 3.7
+ignore_missing_imports = true
+warn_unused_ignores = true
+no_implicit_optional = true