summaryrefslogtreecommitdiff
path: root/.pre-commit-config.yaml
diff options
context:
space:
mode:
authorpre-commit-ci[bot] <66853113+pre-commit-ci[bot]@users.noreply.github.com>2022-10-04 16:19:29 +0000
committerGitHub <noreply@github.com>2022-10-04 16:19:29 +0000
commit320add3fe2d090d451fa684792edbfc89fc7b7f3 (patch)
tree2b425a3e13277644836a0d5dadc2c7eb1f5c3dbd /.pre-commit-config.yaml
parentbe76c05f937a55a6d0e46443787e0e8bb527b9c3 (diff)
downloadpylint-git-320add3fe2d090d451fa684792edbfc89fc7b7f3.tar.gz
[pre-commit.ci] pre-commit autoupdate (#7566)
* Remove noqa for a false positive that was fixed in latest mypy Co-authored-by: Pierre Sassoulas <pierre.sassoulas@gmail.com>
Diffstat (limited to '.pre-commit-config.yaml')
-rw-r--r--.pre-commit-config.yaml4
1 files changed, 2 insertions, 2 deletions
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
index c516282e0..834c9456f 100644
--- a/.pre-commit-config.yaml
+++ b/.pre-commit-config.yaml
@@ -33,7 +33,7 @@ repos:
exclude: tests(/\w*)*/functional/|tests/input|doc/data/messages|examples/|setup.py|tests(/\w*)*data/
types: [python]
- repo: https://github.com/asottile/pyupgrade
- rev: v2.38.2
+ rev: v3.0.0
hooks:
- id: pyupgrade
args: [--py37-plus]
@@ -100,7 +100,7 @@ repos:
files: ^(doc/(.*/)*.*\.rst)
additional_dependencies: [Sphinx==5.0.1]
- repo: https://github.com/pre-commit/mirrors-mypy
- rev: v0.971
+ rev: v0.982
hooks:
- id: mypy
name: mypy