summaryrefslogtreecommitdiff
path: root/.pre-commit-config.yaml
diff options
context:
space:
mode:
authorpre-commit-ci[bot] <66853113+pre-commit-ci[bot]@users.noreply.github.com>2022-11-01 07:33:58 +0100
committerGitHub <noreply@github.com>2022-11-01 07:33:58 +0100
commit583adcdca0fb86e9df7ffaa4b95117b92994040b (patch)
tree6e18e0c057df90eb31147e0403af9617ba4bad1d /.pre-commit-config.yaml
parent6c81cc93e6b79a2564e4ce02088a34a7ec2bbfaa (diff)
downloadpylint-git-583adcdca0fb86e9df7ffaa4b95117b92994040b.tar.gz
[pre-commit.ci] pre-commit autoupdate (#7696)
* [pre-commit.ci] pre-commit autoupdate updates: - [github.com/asottile/pyupgrade: v3.1.0 → v3.2.0](https://github.com/asottile/pyupgrade/compare/v3.1.0...v3.2.0) - [github.com/pre-commit/mirrors-prettier: v3.0.0-alpha.3 → v3.0.0-alpha.4](https://github.com/pre-commit/mirrors-prettier/compare/v3.0.0-alpha.3...v3.0.0-alpha.4) * Also upgrade additional dependencies for flake8 plugins Co-authored-by: pre-commit-ci[bot] <66853113+pre-commit-ci[bot]@users.noreply.github.com> Co-authored-by: Pierre Sassoulas <pierre.sassoulas@gmail.com>
Diffstat (limited to '.pre-commit-config.yaml')
-rw-r--r--.pre-commit-config.yaml6
1 files changed, 3 insertions, 3 deletions
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
index 28b54c4ed..d749de5d0 100644
--- a/.pre-commit-config.yaml
+++ b/.pre-commit-config.yaml
@@ -33,7 +33,7 @@ repos:
exclude: tests(/\w*)*/functional/|tests/input|doc/data/messages|examples/|setup.py|tests(/\w*)*data/
types: [python]
- repo: https://github.com/asottile/pyupgrade
- rev: v3.1.0
+ rev: v3.2.0
hooks:
- id: pyupgrade
args: [--py37-plus]
@@ -57,7 +57,7 @@ repos:
rev: 5.0.4
hooks:
- id: flake8
- additional_dependencies: [flake8-typing-imports==1.12.0]
+ additional_dependencies: [flake8-typing-imports==1.14.0]
exclude: *fixtures
- repo: local
hooks:
@@ -119,7 +119,7 @@ repos:
]
exclude: tests(/\w*)*/functional/|tests/input|tests(/.*)+/conftest.py|doc/data/messages|tests(/\w*)*data/
- repo: https://github.com/pre-commit/mirrors-prettier
- rev: v3.0.0-alpha.3
+ rev: v3.0.0-alpha.4
hooks:
- id: prettier
args: [--prose-wrap=always, --print-width=88]