summaryrefslogtreecommitdiff
path: root/.pre-commit-config.yaml
diff options
context:
space:
mode:
authorDaniël van Noord <13665637+DanielNoord@users.noreply.github.com>2022-03-25 09:51:14 +0100
committerDaniël van Noord <13665637+DanielNoord@users.noreply.github.com>2022-03-25 10:02:06 +0100
commite73cfa840d47bee796795517c6d87906b81069d1 (patch)
tree80eb738478a0a643daf219b90c2fedbc6ba8b02e /.pre-commit-config.yaml
parent3d95d39ad707cb26f003d180ed43e2670852bb96 (diff)
downloadpylint-git-e73cfa840d47bee796795517c6d87906b81069d1.tar.gz
Update configuration of pre-commit hooks and tools
Diffstat (limited to '.pre-commit-config.yaml')
-rw-r--r--.pre-commit-config.yaml20
1 files changed, 6 insertions, 14 deletions
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
index 6bd4832de..c8a6c58f6 100644
--- a/.pre-commit-config.yaml
+++ b/.pre-commit-config.yaml
@@ -13,7 +13,7 @@ repos:
rev: v1.4
hooks:
- id: autoflake
- exclude: &fixtures tests/functional/|tests/input|tests/regrtest_data/|tests/data/|doc/data/messages|tests/testutils/data/
+ exclude: &fixtures tests/functional/|tests/input|doc/data/messages|tests(/\w*)*data/
args:
- --in-place
- --remove-all-unused-imports
@@ -25,7 +25,7 @@ repos:
hooks:
- id: copyright-notice
args: ["--notice=script/copyright.txt", "--enforce-all"]
- exclude: tests/functional/|tests/input|tests/regrtest_data/|tests/data/|doc/data/messages|tests/testutils/data/|examples/|setup.py
+ exclude: tests/functional/|tests/input|doc/data/messages|examples/|setup.py|tests(/\w*)*data/
types: [python]
- repo: https://github.com/asottile/pyupgrade
rev: v2.31.1
@@ -60,16 +60,8 @@ repos:
entry: pylint
language: system
types: [python]
- args:
- [
- "-rn",
- "-sn",
- "--rcfile=pylintrc",
- "--fail-on=I",
- "--load-plugins=pylint.extensions.docparams",
- ]
- # disabled plugins: pylint.extensions.mccabe
- exclude: tests/functional/|tests/input|tests/extensions/data|tests/regrtest_data/|tests/data/|doc/
+ args: ["-rn", "-sn", "--rcfile=pylintrc", "--fail-on=I"]
+ exclude: tests/functional/|tests/input|tests(/\w*)*data/|doc/
- id: fix-documentation
name: Fix documentation
entry: python3 -m script.fix_documentation
@@ -94,13 +86,13 @@ repos:
args: []
require_serial: true
additional_dependencies: ["platformdirs==2.2.0", "types-pkg_resources==0.1.3"]
- exclude: tests/functional/|tests/input|tests(/.*)*/data|tests/regrtest_data/|tests/data/|tests(/.*)+/conftest.py|doc/|bin/
+ exclude: tests/functional/|tests/input|tests(/.*)+/conftest.py|doc/data/messages|tests(/\w*)*data/
- repo: https://github.com/pre-commit/mirrors-prettier
rev: v2.6.0
hooks:
- id: prettier
args: [--prose-wrap=always, --print-width=88]
- exclude: tests(/.*)*/data
+ exclude: tests(/\w*)*data/
- repo: https://github.com/DanielNoord/pydocstringformatter
rev: v0.5.3
hooks: