summaryrefslogtreecommitdiff
path: root/.pre-commit-config.yaml
diff options
context:
space:
mode:
authorPierre Sassoulas <pierre.sassoulas@gmail.com>2022-03-01 16:04:49 +0100
committerPierre Sassoulas <pierre.sassoulas@gmail.com>2022-03-24 13:06:15 +0100
commitec4a3f7f1eac9e605b35d1ac56680e1608c48be3 (patch)
tree5cf16665b7797bbe17e71f0f886a744e83bd034a /.pre-commit-config.yaml
parent9e0baf370a15fecf3360996a6a2ead688fc61894 (diff)
downloadpylint-git-ec4a3f7f1eac9e605b35d1ac56680e1608c48be3.tar.gz
Add a pre-commit hook to check the copyright notice
Fix the existing file so they have a notice. No header for setup.py or examples or doc
Diffstat (limited to '.pre-commit-config.yaml')
-rw-r--r--.pre-commit-config.yaml9
1 files changed, 8 insertions, 1 deletions
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
index f19027503..6bd4832de 100644
--- a/.pre-commit-config.yaml
+++ b/.pre-commit-config.yaml
@@ -13,13 +13,20 @@ repos:
rev: v1.4
hooks:
- id: autoflake
- exclude: &fixtures tests/functional/|tests/input|tests/regrtest_data/|tests/data/|doc/data/messages
+ exclude: &fixtures tests/functional/|tests/input|tests/regrtest_data/|tests/data/|doc/data/messages|tests/testutils/data/
args:
- --in-place
- --remove-all-unused-imports
- --expand-star-imports
- --remove-duplicate-keys
- --remove-unused-variables
+ - repo: https://github.com/Pierre-Sassoulas/copyright_notice_precommit
+ rev: f683ab7d10d5f7e779c75aea17197007583d14e4
+ hooks:
+ - id: copyright-notice
+ args: ["--notice=script/copyright.txt", "--enforce-all"]
+ exclude: tests/functional/|tests/input|tests/regrtest_data/|tests/data/|doc/data/messages|tests/testutils/data/|examples/|setup.py
+ types: [python]
- repo: https://github.com/asottile/pyupgrade
rev: v2.31.1
hooks: