summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmile Anclin <emile.anclin@logilab.fr>2010-11-15 15:56:13 +0100
committerEmile Anclin <emile.anclin@logilab.fr>2010-11-15 15:56:13 +0100
commit566815597c3ebf327c8c84932f48c3649304c4e5 (patch)
tree39c29948f2b18d2c4d4b1d8b372c3fc7e30227ed
parent3ff282ffef9f010bca780f506e525924f64c1f24 (diff)
downloadpylint-git-pylint-version-0.22.0.tar.gz
prepare 0.22.0pylint-version-0.22.0
-rw-r--r--ChangeLog4
-rw-r--r--__pkginfo__.py7
-rwxr-xr-xdebian.py3k/rules5
-rw-r--r--debian/changelog6
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules8
6 files changed, 22 insertions, 10 deletions
diff --git a/ChangeLog b/ChangeLog
index ff5cd3eb6..c7bfced20 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,6 +1,10 @@
ChangeLog for PyLint
====================
+2010-11-15 -- 0.22.0
+
+ * python versions: minimal python3.x support; drop python < 2.5 support
+
2010-10-27 -- 0.21.4
* fix #48066: pylint crashes when redirecting output containing non-ascii characters
diff --git a/__pkginfo__.py b/__pkginfo__.py
index 5fc62fae9..4b0edcb51 100644
--- a/__pkginfo__.py
+++ b/__pkginfo__.py
@@ -18,11 +18,10 @@
modname = distname = 'pylint'
-numversion = (0, 21, 4)
+numversion = (0, 22, 0)
version = '.'.join([str(num) for num in numversion])
-install_requires = ['logilab-common >= 0.52.1',
- 'logilab-astng >= 0.20.4']
+install_requires = ['logilab-common >= 0.53.0', 'logilab-astng >= 0.21.0']
license = 'GPL'
description = "python code static checker"
@@ -58,8 +57,6 @@ long_desc = """\
.
Additionally, it is possible to write plugins to add your own checks."""
-pyversions = ["2.3", "2.4", "2.5", '2.6', "2.7"]
-
from os.path import join
scripts = [join('bin', filename)
for filename in ('pylint', 'pylint-gui', "symilar", "epylint",
diff --git a/debian.py3k/rules b/debian.py3k/rules
index d4ae43dc8..5d4f1f969 100755
--- a/debian.py3k/rules
+++ b/debian.py3k/rules
@@ -42,10 +42,15 @@ install: build
--root=$(CURDIR)/debian/$(PACKAGE)/ \
${py_setup_install_args}
find $(CURDIR)/debian/$(PACKAGE)/usr/lib/python*/*-packages/ ! -path "*/test/*py" -name "*py" -exec 2to3-3.1 -wn {} \;
+ for executable in pylint pylint-gui symilar epylint pyreverse ; do \
+ new_exec="$$executable"3; \
+ mv -v $(CURDIR)/debian/$(PACKAGE)/usr/bin/$$executable $(CURDIR)/debian/$(PACKAGE)/usr/bin/$$new_exec; \
+ done
# remove test directory
rm -rf debian/$(PACKAGE)/usr/lib/python*/*-packages/pylint/test
+
# Build architecture-independent files here.
binary-indep: build install
dh_testdir
diff --git a/debian/changelog b/debian/changelog
index c39a6e6ee..da8c86bd3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+pylint (0.22.0-1) unstable; urgency=low
+
+ * new upstream release
+
+ -- Émile Anclin <emile.anclin@logilab.fr> Mon, 15 Nov 2010 15:54:44 +0100
+
pylint (0.21.4-1) unstable; urgency=low
* new upstream release
diff --git a/debian/control b/debian/control
index 7c631851f..9a0bbaa37 100644
--- a/debian/control
+++ b/debian/control
@@ -13,7 +13,7 @@ Vcs-Browser: http://svn.debian.org/viewsvn/python-apps/packages/pylint/trunk/
Package: pylint
Architecture: all
-Depends: ${python:Depends}, ${misc:Depends}, python-logilab-common (>= 0.52.1), python-logilab-astng (>= 0.20.4)
+Depends: ${python:Depends}, ${misc:Depends}, python-logilab-common (>= 0.53.0), python-logilab-astng (>= 0.21.0)
Recommends: python-tk
XB-Python-Version: ${python:Versions}
Conflicts: python2.2-pylint, python2.3-pylint, python2.4-pylint, pylint-common, pylint-test
diff --git a/debian/rules b/debian/rules
index e68116e51..7eac66e23 100755
--- a/debian/rules
+++ b/debian/rules
@@ -42,11 +42,11 @@ install: build
rm -rf debian/pylint/usr/lib/python*/*-packages/pylint/test
# fixes shebangs
- for exec in pylint pylint-gui symilar ; do \
- if head -1 debian/pylint/usr/bin/$$exec | grep "^#! */usr/bin" | grep "python" >/dev/null ; then \
- sed -i "s@^#! */usr/bin/env \+python\$$@#!/usr/bin/python@" debian/pylint/usr/bin/$$exec; \
+ for exec_file in pylint pylint-gui symilar epylint pyreverse ; do \
+ if head -1 debian/pylint/usr/bin/$$exec_file | grep "^#! */usr/bin" | grep "python" >/dev/null ; then \
+ sed -i "s@^#! */usr/bin/env \+python\$$@#!/usr/bin/python@" debian/pylint/usr/bin/$$exec_file; \
fi ; \
- chmod a+x debian/pylint/usr/bin/$$exec; \
+ chmod a+x debian/pylint/usr/bin/$$exec_file; \
done
install -m 644 elisp/pylint.el debian/pylint/usr/share/emacs/site-lisp/pylint/