summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Sassoulas <pierre.sassoulas@gmail.com>2023-01-12 23:17:03 +0100
committerPierre Sassoulas <pierre.sassoulas@gmail.com>2023-01-13 11:26:46 +0100
commit361a1f7533ccfcec58eb10fb517cc5b278fec411 (patch)
treef2e5872a9c5108036f3095c33a49231a1c39f5ec
parent2c2fb00c64f06286051bb0ab48f0c73b6925c2f5 (diff)
downloadpylint-git-2.16.0b0.tar.gz
Bump pylint to 2.16.0-b0, update changelogv2.16.0b0
-rw-r--r--CONTRIBUTORS.txt14
-rw-r--r--doc/user_guide/checkers/features.rst6
-rw-r--r--doc/user_guide/configuration/all-options.rst2
-rw-r--r--doc/user_guide/messages/messages_overview.rst2
-rw-r--r--examples/pylintrc11
-rw-r--r--examples/pyproject.toml11
-rw-r--r--pylint/__pkginfo__.py2
-rw-r--r--script/.contributors_aliases.json12
-rw-r--r--tbump.toml2
9 files changed, 35 insertions, 27 deletions
diff --git a/CONTRIBUTORS.txt b/CONTRIBUTORS.txt
index b7e937b4a..382098cb0 100644
--- a/CONTRIBUTORS.txt
+++ b/CONTRIBUTORS.txt
@@ -555,6 +555,20 @@ contributors:
* Added ignore_signatures to duplicate checker
- Adam Dangoor <adamdangoor@gmail.com>
- 243f6a88 85a308d3 <33170174+243f6a8885a308d313198a2e037@users.noreply.github.com>
+- Zen Lee <53538590+zenlyj@users.noreply.github.com>
+- sur.la.route <17788706+christopherpickering@users.noreply.github.com>
+- kriek <sylvain.ackermann@gmail.com>
+- Robert Hofer <hofrob@protonmail.com>
+- Ramon Saraiva <ramonsaraiva@gmail.com>
+- Osher De Paz <odepaz@redhat.com>
+- Lumír 'Frenzy' Balhar <frenzy.madness@gmail.com>
+- James Addison <55152140+jayaddison@users.noreply.github.com>
+- Eddie Darling <eddie.darling@genapsys.com>
+- David Lawson <dmrlawson@gmail.com>
+- Cubicpath <Cubicpath@protonmail.com>
+- Cosmo <cosmo@cosmo.red>
+- Brice Chardin <brice.chardin@gmail.com>
+- Alvaro Frias Garay <alvaro.frias@eclypsium.com>
Co-Author
diff --git a/doc/user_guide/checkers/features.rst b/doc/user_guide/checkers/features.rst
index 3992d93d4..e92e8a553 100644
--- a/doc/user_guide/checkers/features.rst
+++ b/doc/user_guide/checkers/features.rst
@@ -121,6 +121,9 @@ Basic checker Messages
Loops should only have an else clause if they can exit early with a break
statement, otherwise the statements under else should be on the same scope as
the loop itself.
+:pointless-exception-statement (W0133): *Exception statement has no effect*
+ Used when an exception is created without being assigned, raised or returned
+ for subsequent use elsewhere.
:expression-not-assigned (W0106): *Expression "%s" is assigned to nothing*
Used when an expression that is not a function call is assigned to nothing.
Probably something else was intended.
@@ -147,9 +150,6 @@ Basic checker Messages
This is a particular case of W0104 with its own message so you can easily
disable it if you're using those strings as documentation, instead of
comments.
-:pointless-exception-statement (W0132): *Exception statement has no effect*
- Used when an exception is created without being assigned, raised or returned
- for subsequent use elsewhere.
:unnecessary-pass (W0107): *Unnecessary pass statement*
Used when a "pass" statement that can be avoided is encountered.
:unreachable (W0101): *Unreachable code*
diff --git a/doc/user_guide/configuration/all-options.rst b/doc/user_guide/configuration/all-options.rst
index 85723d6bf..d284d1194 100644
--- a/doc/user_guide/configuration/all-options.rst
+++ b/doc/user_guide/configuration/all-options.rst
@@ -1719,7 +1719,7 @@ Extensions
---------------------------
--valid-magic-values
""""""""""""""""""""
-* List of valid magic values that `magic-value-compare` will not detect.*
+*List of valid magic values that `magic-value-compare` will not detect. Supports integers, floats, negative numbers, for empty string enter ``''``, for backslash values just use one backslash e.g \n.*
**Default:** ``(0, -1, 1, '', '__main__')``
diff --git a/doc/user_guide/messages/messages_overview.rst b/doc/user_guide/messages/messages_overview.rst
index 648b4b373..51dcf0cd5 100644
--- a/doc/user_guide/messages/messages_overview.rst
+++ b/doc/user_guide/messages/messages_overview.rst
@@ -286,8 +286,8 @@ All messages in the warning category:
warning/non-str-assignment-to-dunder-name
warning/overlapping-except
warning/overridden-final-method
- warning/pointless-statement
warning/pointless-exception-statement
+ warning/pointless-statement
warning/pointless-string-statement
warning/possibly-unused-variable
warning/preferred-module
diff --git a/examples/pylintrc b/examples/pylintrc
index aa9db9dcf..a69f91575 100644
--- a/examples/pylintrc
+++ b/examples/pylintrc
@@ -5,8 +5,8 @@
# only in one or another interpreter, leading to false positives when analysed.
analyse-fallback-blocks=no
-# Clear in-memory caches upon conclusion of linting. Useful if running pylint in
-# a server-like mode.
+# Clear in-memory caches upon conclusion of linting. Useful if running pylint
+# in a server-like mode.
clear-cache-post-run=no
# Load and enable all available extensions. Use --list-extensions to see a list
@@ -50,8 +50,8 @@ ignore=CVS
# Add files or directories matching the regular expressions patterns to the
# ignore-list. The regex matches against paths and can be in Posix or Windows
-# format. Because '\' represents the directory delimiter on Windows systems, it
-# can't be used as an escape character.
+# format. Because '\\' represents the directory delimiter on Windows systems,
+# it can't be used as an escape character.
ignore-paths=
# Files or directories matching the regular expression patterns are skipped.
@@ -311,8 +311,7 @@ min-public-methods=2
[EXCEPTIONS]
# Exceptions that will emit a warning when caught.
-overgeneral-exceptions=builtins.BaseException,
- builtins.Exception
+overgeneral-exceptions=builtins.BaseException,builtins.Exception
[FORMAT]
diff --git a/examples/pyproject.toml b/examples/pyproject.toml
index 16f528327..d3b8b9052 100644
--- a/examples/pyproject.toml
+++ b/examples/pyproject.toml
@@ -40,7 +40,7 @@ ignore = ["CVS"]
# Add files or directories matching the regular expressions patterns to the
# ignore-list. The regex matches against paths and can be in Posix or Windows
-# format. Because '\' represents the directory delimiter on Windows systems, it
+# format. Because '\\' represents the directory delimiter on Windows systems, it
# can't be used as an escape character.
# ignore-paths =
@@ -442,15 +442,6 @@ spelling-ignore-comment-directives = "fmt: on,fmt: off,noqa:,noqa,nosec,isort:sk
# --spelling-private-dict-file option) instead of raising a message.
# spelling-store-unknown-words =
-[tool.pylint.string]
-# This flag controls whether inconsistent-quotes generates a warning when the
-# character used as a quote delimiter is used inconsistently within a module.
-# check-quote-consistency =
-
-# This flag controls whether the implicit-str-concat should generate a warning on
-# implicit string concatenation in sequences defined over several lines.
-# check-str-concat-over-line-jumps =
-
[tool.pylint.typecheck]
# List of decorators that produce context managers, such as
# contextlib.contextmanager. Add to this list to register other decorators that
diff --git a/pylint/__pkginfo__.py b/pylint/__pkginfo__.py
index 7d767f3a1..d188fe5b4 100644
--- a/pylint/__pkginfo__.py
+++ b/pylint/__pkginfo__.py
@@ -9,7 +9,7 @@ It's updated via tbump, do not modify.
from __future__ import annotations
-__version__ = "2.16.0-dev"
+__version__ = "2.16.0b0"
def get_numversion_from_version(v: str) -> tuple[int, int, int]:
diff --git a/script/.contributors_aliases.json b/script/.contributors_aliases.json
index 3adba8f78..19e620f7c 100644
--- a/script/.contributors_aliases.json
+++ b/script/.contributors_aliases.json
@@ -71,6 +71,10 @@
"mails": ["46202743+lorena-b@users.noreply.github.com"],
"name": "Lorena Buciu"
},
+ "53538590+zenlyj@users.noreply.github.com": {
+ "mails": ["53538590+zenlyj@users.noreply.github.com"],
+ "name": "Zen Lee"
+ },
"53625739+dbrookman@users.noreply.github.com": {
"mails": ["53625739+dbrookman@users.noreply.github.com"],
"name": "Daniel Brookman"
@@ -347,6 +351,10 @@
"mails": ["hg@stevenmyint.com", "git@stevenmyint.com"],
"name": "Steven Myint"
},
+ "hofrob@protonmail.com": {
+ "mails": ["hofrob@protonmail.com"],
+ "name": "Robert Hofer"
+ },
"hugovk@users.noreply.github.com": {
"mails": ["hugovk@users.noreply.github.com"],
"name": "Hugo van Kemenade"
@@ -603,9 +611,5 @@
"yileiyang@google.com": {
"mails": ["yileiyang@google.com"],
"name": "Yilei \"Dolee\" Yang"
- },
- "hofrob@protonmail.com": {
- "mails": ["hofrob@protonmail.com"],
- "name": "Robert Hofer"
}
}
diff --git a/tbump.toml b/tbump.toml
index 3b61c031d..92590505c 100644
--- a/tbump.toml
+++ b/tbump.toml
@@ -1,7 +1,7 @@
github_url = "https://github.com/PyCQA/pylint"
[version]
-current = "2.16.0-dev"
+current = "2.16.0b0"
regex = '''
^(?P<major>0|[1-9]\d*)
\.