summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Sassoulas <pierre.sassoulas@gmail.com>2021-06-29 20:59:39 +0200
committerPierre Sassoulas <pierre.sassoulas@gmail.com>2021-06-29 21:13:47 +0200
commita56b52550b88ba4234f1332b54c5cfd3e49368b3 (patch)
tree5c1f0f585f720af4deba3459ea4f547b4a921365
parentca447f7d93a002eb7d4dd80ff4caaf28ce8702b6 (diff)
downloadpylint-git-2.9.0.tar.gz
Bump pylint to 2.9.0, update changelog, add python 3.10 to package metav2.9.0
-rw-r--r--ChangeLog34
-rw-r--r--pylint/__pkginfo__.py2
-rw-r--r--pylint/checkers/base.py1
-rw-r--r--pylint/checkers/utils.py1
-rw-r--r--pylint/checkers/variables.py2
-rw-r--r--pylint/extensions/_check_docs_utils.py2
-rw-r--r--pylint/extensions/confusing_elif.py2
-rw-r--r--pylint/pyreverse/diagrams.py1
-rw-r--r--pylint/pyreverse/inspector.py1
-rw-r--r--pylint/pyreverse/main.py2
-rw-r--r--pylint/pyreverse/utils.py1
-rw-r--r--pylint/pyreverse/writer.py2
-rw-r--r--setup.cfg1
-rw-r--r--tbump.toml2
-rw-r--r--tests/checkers/unittest_variables.py1
-rw-r--r--tests/unittest_pyreverse_writer.py2
16 files changed, 40 insertions, 17 deletions
diff --git a/ChangeLog b/ChangeLog
index f636953ea..af6fb0db6 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -2,12 +2,28 @@
Pylint's ChangeLog
------------------
-What's New in Pylint 2.9.0?
+What's New in Pylint 2.10.0?
+============================
+Release date: TBA
+
+..
+ Put new features here and also in 'doc/whatsnew/2.10.rst'
+
+
+What's New in Pylint 2.9.1?
===========================
Release date: TBA
..
- Put new features and bugfixes here and also in 'doc/whatsnew/2.9.rst'
+ Put bug fixes that should not wait for a new minor version here
+
+
+
+What's New in Pylint 2.9.0?
+===========================
+Release date: 2021-06-29
+
+* Python 3.10 is now supported.
* Add type annotations to pyreverse dot files
@@ -18,7 +34,7 @@ Release date: TBA
Closes #4618
-* astroid has been upgraded to 2.6.0
+* astroid has been upgraded to 2.6.1
* Added various deprecated functions/methods for python 3.10, 3.7, 3.6 and 3.3
@@ -36,8 +52,6 @@ Release date: TBA
Closes #4612
-* Appveyor is no longer used in the continuous integration
-
* Added ``deprecated-decorator``: Emitted when deprecated decorator is used.
Closes #4429
@@ -137,7 +151,7 @@ Release date: TBA
* Fix a crash when a plugin from the configuration could not be loaded and raise an error
'bad-plugin-value' instead
-Closes #4555
+ Closes #4555
* Added handling of floating point values when parsing configuration from pyproject.toml
@@ -174,11 +188,11 @@ Closes #4555
consistency. As such they don't necessarily provide a performance benefit
and are often times opinionated.
- * New checker ``consider-using-tuple``. Emitted when an in-place defined
- list or set can be replaced by a tuple.
+* New checker ``consider-using-tuple``. Emitted when an in-place defined
+ list or set can be replaced by a tuple.
- * New checker ``consider-using-namedtuple-or-dataclass``. Emitted when dictionary values
- can be replaced by namedtuples or dataclass instances.
+* New checker ``consider-using-namedtuple-or-dataclass``. Emitted when dictionary values
+ can be replaced by namedtuples or dataclass instances.
* Fix error that occurred when using ``slice`` as subscript for dict.
diff --git a/pylint/__pkginfo__.py b/pylint/__pkginfo__.py
index 681c69340..47b145cb8 100644
--- a/pylint/__pkginfo__.py
+++ b/pylint/__pkginfo__.py
@@ -2,7 +2,7 @@
# For details: https://github.com/PyCQA/pylint/blob/master/LICENSE
from typing import Tuple
-__version__ = "2.9.0-dev1"
+__version__ = "2.9.0"
def get_numversion_from_version(v: str) -> Tuple:
diff --git a/pylint/checkers/base.py b/pylint/checkers/base.py
index cd753a4c8..98cf1ba09 100644
--- a/pylint/checkers/base.py
+++ b/pylint/checkers/base.py
@@ -52,6 +52,7 @@
# Copyright (c) 2020 Gabriel R Sezefredo <g@briel.dev>
# Copyright (c) 2020 Benny <benny.mueller91@gmail.com>
# Copyright (c) 2020 Anubhav <35621759+anubh-v@users.noreply.github.com>
+# Copyright (c) 2021 Lorena B <46202743+lorena-b@users.noreply.github.com>
# Copyright (c) 2021 Marc Mueller <30130371+cdce8p@users.noreply.github.com>
# Copyright (c) 2021 David Liu <david@cs.toronto.edu>
# Copyright (c) 2021 Andreas Finkler <andi.finkler@gmail.com>
diff --git a/pylint/checkers/utils.py b/pylint/checkers/utils.py
index 40a09ad87..6e884745c 100644
--- a/pylint/checkers/utils.py
+++ b/pylint/checkers/utils.py
@@ -41,6 +41,7 @@
# Copyright (c) 2020 Ram Rachum <ram@rachum.com>
# Copyright (c) 2020 Slavfox <slavfoxman@gmail.com>
# Copyright (c) 2020 Anthony Sottile <asottile@umich.edu>
+# Copyright (c) 2021 Lorena B <46202743+lorena-b@users.noreply.github.com>
# Copyright (c) 2021 Marc Mueller <30130371+cdce8p@users.noreply.github.com>
# Copyright (c) 2021 yushao2 <36848472+yushao2@users.noreply.github.com>
diff --git a/pylint/checkers/variables.py b/pylint/checkers/variables.py
index 8a4637509..4f3d97e8b 100644
--- a/pylint/checkers/variables.py
+++ b/pylint/checkers/variables.py
@@ -39,6 +39,8 @@
# Copyright (c) 2020 Andrew Simmons <a.simmons@deakin.edu.au>
# Copyright (c) 2020 Anthony Sottile <asottile@umich.edu>
# Copyright (c) 2020 Ashley Whetter <ashleyw@activestate.com>
+# Copyright (c) 2021 Sergei Lebedev <185856+superbobry@users.noreply.github.com>
+# Copyright (c) 2021 Lorena B <46202743+lorena-b@users.noreply.github.com>
# Copyright (c) 2021 Marc Mueller <30130371+cdce8p@users.noreply.github.com>
# Copyright (c) 2021 haasea <44787650+haasea@users.noreply.github.com>
# Copyright (c) 2021 Alexander Kapshuna <kapsh@kap.sh>
diff --git a/pylint/extensions/_check_docs_utils.py b/pylint/extensions/_check_docs_utils.py
index de2f427bf..9f8f4f0c4 100644
--- a/pylint/extensions/_check_docs_utils.py
+++ b/pylint/extensions/_check_docs_utils.py
@@ -13,8 +13,8 @@
# Copyright (c) 2019 Hugo van Kemenade <hugovk@users.noreply.github.com>
# Copyright (c) 2019 Danny Hermes <daniel.j.hermes@gmail.com>
# Copyright (c) 2019 Zeb Nicholls <zebedee.nicholls@climate-energy-college.org>
-# Copyright (c) 2021 Marc Mueller <30130371+cdce8p@users.noreply.github.com>
# Copyright (c) 2021 Pierre Sassoulas <pierre.sassoulas@gmail.com>
+# Copyright (c) 2021 Marc Mueller <30130371+cdce8p@users.noreply.github.com>
# Licensed under the GPL: https://www.gnu.org/licenses/old-licenses/gpl-2.0.html
# For details: https://github.com/PyCQA/pylint/blob/master/LICENSE
diff --git a/pylint/extensions/confusing_elif.py b/pylint/extensions/confusing_elif.py
index d36fb8c57..50197b572 100644
--- a/pylint/extensions/confusing_elif.py
+++ b/pylint/extensions/confusing_elif.py
@@ -1,5 +1,5 @@
-# Copyright (c) 2021 Pierre Sassoulas <pierre.sassoulas@gmail.com>
# Copyright (c) 2021 Andreas Finkler <andi.finkler@gmail.com>
+# Copyright (c) 2021 Pierre Sassoulas <pierre.sassoulas@gmail.com>
# Licensed under the GPL: https://www.gnu.org/licenses/old-licenses/gpl-2.0.html
# For details: https://github.com/PyCQA/pylint/blob/master/LICENSE
diff --git a/pylint/pyreverse/diagrams.py b/pylint/pyreverse/diagrams.py
index 4c391c7fa..52f4c0f77 100644
--- a/pylint/pyreverse/diagrams.py
+++ b/pylint/pyreverse/diagrams.py
@@ -6,6 +6,7 @@
# Copyright (c) 2018 ssolanki <sushobhitsolanki@gmail.com>
# Copyright (c) 2019-2021 Pierre Sassoulas <pierre.sassoulas@gmail.com>
# Copyright (c) 2020 hippo91 <guillaume.peillex@gmail.com>
+# Copyright (c) 2021 Mark Byrne <31762852+mbyrnepr2@users.noreply.github.com>
# Licensed under the GPL: https://www.gnu.org/licenses/old-licenses/gpl-2.0.html
# For details: https://github.com/PyCQA/pylint/blob/master/LICENSE
diff --git a/pylint/pyreverse/inspector.py b/pylint/pyreverse/inspector.py
index d6c0bb9c6..3d7d90814 100644
--- a/pylint/pyreverse/inspector.py
+++ b/pylint/pyreverse/inspector.py
@@ -6,6 +6,7 @@
# Copyright (c) 2019 Hugo van Kemenade <hugovk@users.noreply.github.com>
# Copyright (c) 2020 hippo91 <guillaume.peillex@gmail.com>
# Copyright (c) 2020 Anthony Sottile <asottile@umich.edu>
+# Copyright (c) 2021 Mark Byrne <31762852+mbyrnepr2@users.noreply.github.com>
# Licensed under the GPL: https://www.gnu.org/licenses/old-licenses/gpl-2.0.html
# For details: https://github.com/PyCQA/pylint/blob/master/LICENSE
diff --git a/pylint/pyreverse/main.py b/pylint/pyreverse/main.py
index a62a1c2e7..c7679cfee 100644
--- a/pylint/pyreverse/main.py
+++ b/pylint/pyreverse/main.py
@@ -9,7 +9,7 @@
# Copyright (c) 2019 Hugo van Kemenade <hugovk@users.noreply.github.com>
# Copyright (c) 2020 Peter Kolbus <peter.kolbus@gmail.com>
# Copyright (c) 2020 hippo91 <guillaume.peillex@gmail.com>
-# Copyright (c) 2021 Mark Byrne <mbyrnepr2@gmail.com>
+# Copyright (c) 2021 Mark Byrne <31762852+mbyrnepr2@users.noreply.github.com>
# Licensed under the GPL: https://www.gnu.org/licenses/old-licenses/gpl-2.0.html
# For details: https://github.com/PyCQA/pylint/blob/master/LICENSE
diff --git a/pylint/pyreverse/utils.py b/pylint/pyreverse/utils.py
index 1f4a65e5b..9d00e3fec 100644
--- a/pylint/pyreverse/utils.py
+++ b/pylint/pyreverse/utils.py
@@ -10,6 +10,7 @@
# Copyright (c) 2020 yeting li <liyt@ios.ac.cn>
# Copyright (c) 2020 Anthony Sottile <asottile@umich.edu>
# Copyright (c) 2020 bernie gray <bfgray3@users.noreply.github.com>
+# Copyright (c) 2021 Mark Byrne <31762852+mbyrnepr2@users.noreply.github.com>
# Copyright (c) 2021 Andreas Finkler <andi.finkler@gmail.com>
# Licensed under the GPL: https://www.gnu.org/licenses/old-licenses/gpl-2.0.html
diff --git a/pylint/pyreverse/writer.py b/pylint/pyreverse/writer.py
index baafc6904..d230d06d1 100644
--- a/pylint/pyreverse/writer.py
+++ b/pylint/pyreverse/writer.py
@@ -8,8 +8,8 @@
# Copyright (c) 2018 ssolanki <sushobhitsolanki@gmail.com>
# Copyright (c) 2019-2021 Pierre Sassoulas <pierre.sassoulas@gmail.com>
# Copyright (c) 2019 Kylian <development@goudcode.nl>
+# Copyright (c) 2021 Mark Byrne <31762852+mbyrnepr2@users.noreply.github.com>
# Copyright (c) 2021 Andreas Finkler <andi.finkler@gmail.com>
-# Copyright (c) 2021 Mark Byrne <mbyrnepr2@gmail.com>
# Licensed under the GPL: https://www.gnu.org/licenses/old-licenses/gpl-2.0.html
# For details: https://github.com/PyCQA/pylint/blob/master/LICENSE
diff --git a/setup.cfg b/setup.cfg
index 7265d707d..331ea66f8 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -24,6 +24,7 @@ classifiers =
Programming Language :: Python :: 3.7
Programming Language :: Python :: 3.8
Programming Language :: Python :: 3.9
+ Programming Language :: Python :: 3.10
Programming Language :: Python :: Implementation :: CPython
Programming Language :: Python :: Implementation :: PyPy
Topic :: Software Development :: Debuggers
diff --git a/tbump.toml b/tbump.toml
index aa54f05ed..915661cfa 100644
--- a/tbump.toml
+++ b/tbump.toml
@@ -1,7 +1,7 @@
github_url = "https://github.com/PyCQA/pylint"
[version]
-current = "2.9.0-dev1"
+current = "2.9.0"
regex = '''
^(?P<major>0|[1-9]\d*)
\.
diff --git a/tests/checkers/unittest_variables.py b/tests/checkers/unittest_variables.py
index 2a590708d..be7e32fe8 100644
--- a/tests/checkers/unittest_variables.py
+++ b/tests/checkers/unittest_variables.py
@@ -13,6 +13,7 @@
# Copyright (c) 2020 Andrew Simmons <anjsimmo@gmail.com>
# Copyright (c) 2020 Andrew Simmons <a.simmons@deakin.edu.au>
# Copyright (c) 2020 Anthony Sottile <asottile@umich.edu>
+# Copyright (c) 2021 Sergei Lebedev <185856+superbobry@users.noreply.github.com>
# Copyright (c) 2021 Marc Mueller <30130371+cdce8p@users.noreply.github.com>
# Licensed under the GPL: https://www.gnu.org/licenses/old-licenses/gpl-2.0.html
diff --git a/tests/unittest_pyreverse_writer.py b/tests/unittest_pyreverse_writer.py
index 95b1b20e0..16a51f07d 100644
--- a/tests/unittest_pyreverse_writer.py
+++ b/tests/unittest_pyreverse_writer.py
@@ -9,7 +9,7 @@
# Copyright (c) 2019 Ashley Whetter <ashley@awhetter.co.uk>
# Copyright (c) 2020 hippo91 <guillaume.peillex@gmail.com>
# Copyright (c) 2020 Anthony Sottile <asottile@umich.edu>
-# Copyright (c) 2021 Mark Byrne <mbyrnepr2@gmail.com>
+# Copyright (c) 2021 Mark Byrne <31762852+mbyrnepr2@users.noreply.github.com>
# Licensed under the GPL: https://www.gnu.org/licenses/old-licenses/gpl-2.0.html
# For details: https://github.com/PyCQA/pylint/blob/master/LICENSE