summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Mueller <30130371+cdce8p@users.noreply.github.com>2021-02-12 15:40:40 +0100
committerPierre Sassoulas <pierre.sassoulas@gmail.com>2021-02-15 14:34:46 +0100
commit005cf2f317144f6503cfc8d00fbe6a201d0a8b8f (patch)
tree3f3943514f263d85e96e5952ae3f220878462460
parentfada206eef6349280c45b27e48b62c1c309c89c6 (diff)
downloadpylint-git-005cf2f317144f6503cfc8d00fbe6a201d0a8b8f.tar.gz
Drop support for Python 3.5 to fix typing
* Variable annotation (PEP 526) requires Python 3.6
-rw-r--r--.travis.yml4
-rw-r--r--ChangeLog2
-rw-r--r--appveyor.yml3
-rw-r--r--doc/faq.rst2
-rw-r--r--pylint/__pkginfo__.py1
-rw-r--r--setup.py2
-rw-r--r--tox.ini5
7 files changed, 7 insertions, 12 deletions
diff --git a/.travis.yml b/.travis.yml
index de982a62f..e985a2820 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -17,9 +17,7 @@ jobs:
- python: 3.6
env: TOXENV=spelling
- stage: tests-cpython
- python: 3.5
- env: TOXENV=py35
- - python: 3.6
+ python: 3.6
env: TOXENV=py36
- python: 3.7
env: TOXENV=py37
diff --git a/ChangeLog b/ChangeLog
index 4fced02d2..b21d4986d 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -29,6 +29,8 @@ Pylint's ChangeLog
* Fix column metadata for anomalous backslash lints
+* Drop support for Python 3.5
+
What's New in Pylint 2.6.1?
===========================
Release date: TBA
diff --git a/appveyor.yml b/appveyor.yml
index c376d0b11..bf3f73d91 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -4,9 +4,6 @@ cache:
- 'C:\\tmp'
environment:
matrix:
- - PYTHON: "C:\\Python35"
- TOXENV: "py35"
-
- PYTHON: "C:\\Python36"
TOXENV: "py36"
diff --git a/doc/faq.rst b/doc/faq.rst
index 5d797839b..86f1e44e9 100644
--- a/doc/faq.rst
+++ b/doc/faq.rst
@@ -50,7 +50,7 @@ supported.
2.4 What versions of Python is Pylint supporting?
--------------------------------------------------
-The supported running environment since Pylint 2.X is Python 3.5+.
+The supported running environment since Pylint 2.X is Python 3.6+.
3. Running Pylint
diff --git a/pylint/__pkginfo__.py b/pylint/__pkginfo__.py
index 82b503610..db4e42fd1 100644
--- a/pylint/__pkginfo__.py
+++ b/pylint/__pkginfo__.py
@@ -68,7 +68,6 @@ classifiers = [
"Operating System :: OS Independent",
"Programming Language :: Python",
"Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
"Programming Language :: Python :: 3.8",
diff --git a/setup.py b/setup.py
index 901b3ca84..e5dccc3a7 100644
--- a/setup.py
+++ b/setup.py
@@ -153,7 +153,7 @@ def install(**kwargs):
cmdclass=cmdclass,
extras_require=extras_require,
test_suite="test",
- python_requires="~=3.5",
+ python_requires="~=3.6",
setup_requires=pytest_runner,
tests_require=["pytest", "pytest-benchmark"],
project_urls=project_urls,
diff --git a/tox.ini b/tox.ini
index 8ed0d016d..c687f7ab2 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
minversion = 2.4
-envlist = py35, py36, py37, py38, py39, pypy, pylint, benchmark
+envlist = py36, py37, py38, py39, pypy, pylint, benchmark
skip_missing_interpreters = true
[testenv:pylint]
@@ -56,8 +56,7 @@ deps =
https://github.com/PyCQA/astroid/tarball/master#egg=astroid
coverage<5.0
mccabe
- # isort 5 is not compatible with Python 3.5
- py35: isort>=4.2.5,<5
+ isort
pytest
pytest-xdist
pytest-benchmark