summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Sassoulas <pierre.sassoulas@gmail.com>2021-06-17 09:29:24 +0200
committerPierre Sassoulas <pierre.sassoulas@gmail.com>2021-06-17 09:33:46 +0200
commit2d56f515ff4ff9248cfde2c3fd2b2f8b70b099d6 (patch)
tree3e47e432a42ece79bb0c97c6e25c93c787c24d29
parentffab1f81cb9146cdb8dc5d7f95a9807304700c76 (diff)
downloadpylint-git-2d56f515ff4ff9248cfde2c3fd2b2f8b70b099d6.tar.gz
Migration from setuptools_scm to tbump
-rw-r--r--ChangeLog3
-rw-r--r--pylint/__pkginfo__.py7
-rw-r--r--setup.cfg3
-rw-r--r--setup.py2
4 files changed, 6 insertions, 9 deletions
diff --git a/ChangeLog b/ChangeLog
index ea32da8a8..8d88d263f 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -9,6 +9,9 @@ Release date: TBA
..
Put new features and bugfixes here and also in 'doc/whatsnew/2.9.rst'
+* ``setuptools_scm`` has been removed and replaced by ``tbump`` in order to not
+ have hidden runtime dependencies to setuptools
+
* Appveyor is no longer used in the continuous integration
* Added ``deprecated-decorator``: Emitted when deprecated decorator is used.
diff --git a/pylint/__pkginfo__.py b/pylint/__pkginfo__.py
index 1a1d99dd2..88b47fc2c 100644
--- a/pylint/__pkginfo__.py
+++ b/pylint/__pkginfo__.py
@@ -2,12 +2,7 @@
# For details: https://github.com/PyCQA/pylint/blob/master/LICENSE
from typing import Tuple
-from pkg_resources import DistributionNotFound, get_distribution
-
-try:
- __version__ = get_distribution("pylint").version
-except DistributionNotFound:
- __version__ = "2.8.2+"
+__version__ = "2.9.0-dev0"
def get_numversion_from_version(v: str) -> Tuple:
diff --git a/setup.cfg b/setup.cfg
index 963101b65..056e2a62c 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,5 +1,6 @@
[metadata]
name = pylint
+version = attr: pylint.__pkginfo__.__version__
description = python code static checker
long_description = file: README.rst
long_description_content_type = text/x-rst
@@ -45,8 +46,6 @@ install_requires =
mccabe>=0.6,<0.7
toml>=0.7.1
colorama;sys_platform=="win32"
-setup_requires =
- setuptools_scm
python_requires = ~=3.6
[options.packages.find]
diff --git a/setup.py b/setup.py
index d5d43d7c9..606849326 100644
--- a/setup.py
+++ b/setup.py
@@ -1,3 +1,3 @@
from setuptools import setup
-setup(use_scm_version=True)
+setup()