summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Sassoulas <pierre.sassoulas@gmail.com>2023-04-23 13:35:32 +0200
committerGitHub <noreply@github.com>2023-04-23 13:35:32 +0200
commit3d036b78fca6e80222f9ca2ffd0f25950d261aed (patch)
tree8c01bb8dea535dad2f6cb4a95c8ade2cf85bc52a
parent7bde086655a2fcf91fe18b438b7aac4b931f1fe2 (diff)
downloadpylint-git-3d036b78fca6e80222f9ca2ffd0f25950d261aed.tar.gz
Upgrade astroid to 2.15.3 (#8584)
Co-authored-by: Marc Mueller <30130371+cdce8p@users.noreply.github.com>
-rw-r--r--pyproject.toml2
-rw-r--r--requirements_test_min.txt2
2 files changed, 2 insertions, 2 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 304d4f6db..a592b9fbe 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -40,7 +40,7 @@ dependencies = [
# Also upgrade requirements_test_min.txt.
# Pinned to dev of second minor update to allow editable installs and fix primer issues,
# see https://github.com/pylint-dev/astroid/issues/1341
- "astroid>=2.15.2,<=2.17.0-dev0",
+ "astroid>=2.15.3,<=2.17.0-dev0",
"isort>=4.2.5,<6",
"mccabe>=0.6,<0.8",
"tomli>=1.1.0;python_version<'3.11'",
diff --git a/requirements_test_min.txt b/requirements_test_min.txt
index 6c22ebdcd..5592bc7e7 100644
--- a/requirements_test_min.txt
+++ b/requirements_test_min.txt
@@ -1,6 +1,6 @@
-e .[testutils,spelling]
# astroid dependency is also defined in pyproject.toml
-astroid==2.15.2 # Pinned to a specific version for tests
+astroid==2.15.3 # Pinned to a specific version for tests
typing-extensions~=4.5
py~=1.11.0
pytest~=7.3