summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Sassoulas <pierre.sassoulas@gmail.com>2023-04-23 13:35:32 +0200
committerPierre Sassoulas <pierre.sassoulas@gmail.com>2023-04-23 14:00:55 +0200
commit5f7e2a51bf008b0bb4acf2ecbcadcf1c903a72f4 (patch)
tree390977077accfce4bd9800d9ae377ecbb3860aab
parent1dba30b43ce7d2c43e6cc94120d8daca5d9ddabd (diff)
downloadpylint-git-5f7e2a51bf008b0bb4acf2ecbcadcf1c903a72f4.tar.gz
Upgrade astroid to 2.15.3 (#8584)
Co-authored-by: Marc Mueller <30130371+cdce8p@users.noreply.github.com> (cherry picked from commit 3d036b78fca6e80222f9ca2ffd0f25950d261aed)
-rw-r--r--pyproject.toml2
-rw-r--r--requirements_test_min.txt2
2 files changed, 2 insertions, 2 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 559341011..09142f42b 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -39,7 +39,7 @@ dependencies = [
# Also upgrade requirements_test_min.txt.
# Pinned to dev of second minor update to allow editable installs and fix primer issues,
# see https://github.com/pylint-dev/astroid/issues/1341
- "astroid>=2.15.2,<=2.17.0-dev0",
+ "astroid>=2.15.3,<=2.17.0-dev0",
"isort>=4.2.5,<6",
"mccabe>=0.6,<0.8",
"tomli>=1.1.0;python_version<'3.11'",
diff --git a/requirements_test_min.txt b/requirements_test_min.txt
index 08321b54f..801bd5831 100644
--- a/requirements_test_min.txt
+++ b/requirements_test_min.txt
@@ -1,6 +1,6 @@
-e .[testutils,spelling]
# astroid dependency is also defined in pyproject.toml
-astroid==2.15.2 # Pinned to a specific version for tests
+astroid==2.15.3 # Pinned to a specific version for tests
typing-extensions~=4.5
py~=1.11.0
pytest~=7.2