summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Sassoulas <pierre.sassoulas@gmail.com>2022-09-06 12:44:37 +0200
committerPierre Sassoulas <pierre.sassoulas@gmail.com>2022-09-06 23:33:59 +0200
commita21af6a7971f70a8cbd5e89acce213c17c75e813 (patch)
tree59447bcff6a246ed16e87f078b9b5c839aa16886
parentb04722031eef4e9c05c4bdb5a253a8131d2d5fa8 (diff)
downloadpylint-git-a21af6a7971f70a8cbd5e89acce213c17c75e813.tar.gz
Upgrade astroid version following 2.12.8 release
-rw-r--r--.github/workflows/changelog.yml2
-rw-r--r--.github/workflows/checks.yaml2
-rw-r--r--.github/workflows/primer-test.yaml2
-rw-r--r--.github/workflows/primer_comment.yaml2
-rw-r--r--.github/workflows/primer_run_main.yaml2
-rw-r--r--.github/workflows/primer_run_pr.yaml2
-rw-r--r--.github/workflows/tests.yaml2
-rw-r--r--pyproject.toml2
-rw-r--r--requirements_test_min.txt4
9 files changed, 10 insertions, 10 deletions
diff --git a/.github/workflows/changelog.yml b/.github/workflows/changelog.yml
index 1cdfee959..8139f6d6e 100644
--- a/.github/workflows/changelog.yml
+++ b/.github/workflows/changelog.yml
@@ -6,7 +6,7 @@ on:
env:
# Also change CACHE_VERSION in the other workflows
- CACHE_VERSION: 22
+ CACHE_VERSION: 25
DEFAULT_PYTHON: "3.10"
jobs:
diff --git a/.github/workflows/checks.yaml b/.github/workflows/checks.yaml
index 1fb6dde84..f3e5233e8 100644
--- a/.github/workflows/checks.yaml
+++ b/.github/workflows/checks.yaml
@@ -8,7 +8,7 @@ on:
pull_request: ~
env:
- CACHE_VERSION: 22
+ CACHE_VERSION: 25
DEFAULT_PYTHON: "3.10"
PRE_COMMIT_CACHE: ~/.cache/pre-commit
diff --git a/.github/workflows/primer-test.yaml b/.github/workflows/primer-test.yaml
index 145fd70ca..ae30d45d0 100644
--- a/.github/workflows/primer-test.yaml
+++ b/.github/workflows/primer-test.yaml
@@ -13,7 +13,7 @@ on:
- ".github/workflows/primer-test.yaml"
env:
- CACHE_VERSION: 22
+ CACHE_VERSION: 25
concurrency:
group: ${{ github.workflow }}-${{ github.event.pull_request.number || github.ref }}
diff --git a/.github/workflows/primer_comment.yaml b/.github/workflows/primer_comment.yaml
index 21a6bf6bf..f4a145c23 100644
--- a/.github/workflows/primer_comment.yaml
+++ b/.github/workflows/primer_comment.yaml
@@ -14,7 +14,7 @@ on:
env:
# This needs to be the SAME as in the Main and PR job
- CACHE_VERSION: 22
+ CACHE_VERSION: 25
permissions:
contents: read
diff --git a/.github/workflows/primer_run_main.yaml b/.github/workflows/primer_run_main.yaml
index bf719ec67..4e5169d3b 100644
--- a/.github/workflows/primer_run_main.yaml
+++ b/.github/workflows/primer_run_main.yaml
@@ -16,7 +16,7 @@ concurrency:
env:
# This needs to be the SAME as in the PR and comment job
- CACHE_VERSION: 22
+ CACHE_VERSION: 25
jobs:
run-primer:
diff --git a/.github/workflows/primer_run_pr.yaml b/.github/workflows/primer_run_pr.yaml
index b55c57c00..0fb31919c 100644
--- a/.github/workflows/primer_run_pr.yaml
+++ b/.github/workflows/primer_run_pr.yaml
@@ -25,7 +25,7 @@ concurrency:
env:
# This needs to be the SAME as in the Main and comment job
- CACHE_VERSION: 22
+ CACHE_VERSION: 25
jobs:
run-primer:
diff --git a/.github/workflows/tests.yaml b/.github/workflows/tests.yaml
index e35a642aa..dc5579646 100644
--- a/.github/workflows/tests.yaml
+++ b/.github/workflows/tests.yaml
@@ -10,7 +10,7 @@ on:
- doc/data/messages/**
env:
- CACHE_VERSION: 22
+ CACHE_VERSION: 25
jobs:
tests-linux:
diff --git a/pyproject.toml b/pyproject.toml
index 4870201f5..7650c7f11 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -37,7 +37,7 @@ dependencies = [
# Also upgrade requirements_test_min.txt if you are bumping astroid.
# Pinned to dev of second minor update to allow editable installs and fix primer issues,
# see https://github.com/PyCQA/astroid/issues/1341
- "astroid>=2.12.4,<=2.14.0-dev0",
+ "astroid>=2.12.8,<=2.14.0-dev0",
"isort>=4.2.5,<6",
"mccabe>=0.6,<0.8",
"tomli>=1.1.0;python_version<'3.11'",
diff --git a/requirements_test_min.txt b/requirements_test_min.txt
index 4c8946c78..e3f671d73 100644
--- a/requirements_test_min.txt
+++ b/requirements_test_min.txt
@@ -1,9 +1,9 @@
-e .[testutils,spelling]
# astroid dependency is also defined in pyproject.toml
-astroid==2.12.4 # Pinned to a specific version for tests
+astroid==2.12.8 # Pinned to a specific version for tests
typing-extensions~=4.3
pytest~=7.1
pytest-benchmark~=3.4
pytest-timeout~=2.1
-towncrier~=21.9
+towncrier~=22.8
requests