diff options
author | Pierre Sassoulas <pierre.sassoulas@gmail.com> | 2021-04-05 10:27:01 +0200 |
---|---|---|
committer | Pierre Sassoulas <pierre.sassoulas@gmail.com> | 2021-04-05 15:08:27 +0200 |
commit | e7dae22a38086311d69a1fff4f955cf470f0f9da (patch) | |
tree | 510be4c7b15290557c572ae8d788b65a1e651847 | |
parent | 4ef98993a3bf82e6c01e083c417cac8cdd492464 (diff) | |
download | pylint-git-e7dae22a38086311d69a1fff4f955cf470f0f9da.tar.gz |
Remove extra-require from the packaging
-rw-r--r-- | ChangeLog | 2 | ||||
-rw-r--r-- | MANIFEST.in | 1 | ||||
-rw-r--r-- | setup.cfg | 7 | ||||
-rw-r--r-- | setup.py | 25 | ||||
-rw-r--r-- | tox.ini | 6 |
5 files changed, 11 insertions, 30 deletions
@@ -12,6 +12,8 @@ Release date: Undefined * Apply ``const-naming-style`` to module constants annotated with ``typing.Final`` +* The packaging is now done via setuptools exclusively. The 'doc' extra-require has been removed. + What's New in Pylint 2.7.5? =========================== diff --git a/MANIFEST.in b/MANIFEST.in index a114fa1f5..1076efb93 100644 --- a/MANIFEST.in +++ b/MANIFEST.in @@ -2,7 +2,6 @@ include ChangeLog include CONTRIBUTORS.txt include COPYING include README.rst -include requirements_*.txt include elisp/startup elisp/*.el include pytest.ini recursive-include doc *.bat *.png *.py *.svg *.rst *.txt Makefile .md @@ -1,11 +1,13 @@ [metadata] name = pylint license = GPL-2.0-or-later -license_file = COPYING +license_files = + COPYING + CONTRIBUTORS.txt description = python code static checker keywords = static code analysis linter python lint long_description = file: README.rst -long_description_content_type = text/x-rst; charset=UTF-8 +long_description_content_type = text/x-rst author = Python Code Quality Authority author_email = code-quality@python.org url = https://github.com/PyCQA/pylint @@ -35,6 +37,7 @@ classifiers = Topic :: Software Development :: Testing [options] +zip_safe = True packages = find: python_requires = ~=3.6 setup_requires = @@ -12,28 +12,5 @@ __pkginfo__: Dict[str, Any] = {} with open(HERE / "pylint/__pkginfo__.py", encoding="UTF-8") as f: exec(f.read(), __pkginfo__) # pylint: disable=exec-used -with open(HERE / "requirements_docs.txt", encoding="UTF-8") as f: - doc_extra_requires = f.readlines() - -with open(HERE / "requirements_test_min.txt", encoding="UTF-8") as f: - test_requires = f.readlines() - -DEV_REQUIREMENTS_FILES = ["requirements_test.txt", "requirements_test_pre_commit.txt"] -dev_extra_requires = doc_extra_requires + test_requires -for requirement_file in DEV_REQUIREMENTS_FILES: - with open(HERE / requirement_file, encoding="UTF-8") as f: - dev_extra_requires += [ - line for line in f.readlines() if not line.startswith("-r") - ] - - if __name__ == "__main__": - setup( - version=__pkginfo__["__version__"], - tests_require=test_requires, - extras_require={ - ':sys_platform=="win32"': ["colorama"], - "docs": doc_extra_requires, - "dev": dev_extra_requires, - }, - ) + setup(version=__pkginfo__["__version__"]) @@ -7,7 +7,7 @@ skip_missing_interpreters = true [testenv:pylint] deps = -r {toxinidir}/requirements_test_min.txt - pre-commit==2.10.1 + pre-commit~=2.11 commands = pre-commit run pylint --all-files @@ -16,7 +16,7 @@ commands = basepython = python3 deps = -r {toxinidir}/requirements_test_min.txt - pre-commit==2.10.1 + pre-commit~=2.11 commands = pre-commit run --all-files @@ -24,7 +24,7 @@ commands = [testenv:mypy] basepython = python3 deps = - pre-commit==2.10.1 + pre-commit~=2.11 commands = pre-commit run mypy --all-files |