summaryrefslogtreecommitdiff
path: root/Dockerfile
diff options
context:
space:
mode:
authorGiuseppe Valente <gvalente@arista.com>2020-10-07 15:51:36 +0200
committerGiuseppe Valente <gvalente@arista.com>2020-10-07 15:53:58 +0200
commitd54fd70bacf3981312b3914b7eb2d5c78d96efe0 (patch)
tree87f93b3754bc184a30b8255a84388a244df40983 /Dockerfile
parent98d2c060ba0dbae6abecff2393cb6dd8a9bde97b (diff)
downloadpylint-git-d54fd70bacf3981312b3914b7eb2d5c78d96efe0.tar.gz
Dockerfile: add alpine-based docker image
Diffstat (limited to 'Dockerfile')
-rw-r--r--Dockerfile7
1 files changed, 7 insertions, 0 deletions
diff --git a/Dockerfile b/Dockerfile
new file mode 100644
index 000000000..aafe62a6a
--- /dev/null
+++ b/Dockerfile
@@ -0,0 +1,7 @@
+FROM python:3.9.0-alpine3.12
+
+COPY ./ /tmp/build
+WORKDIR /tmp/build
+RUN python setup.py install && rm -rf /tmp/build
+
+ENTRYPOINT ["pylint"]