summaryrefslogtreecommitdiff
path: root/README.rst
diff options
context:
space:
mode:
authorClaudiu Popa <pcmanticore@gmail.com>2019-08-19 11:35:59 +0200
committerClaudiu Popa <pcmanticore@gmail.com>2019-08-19 11:36:05 +0200
commit32255df5608bb8b2d5b0bc05bf70712b61f44204 (patch)
treeff7aac3c4d4710e06825f1de984e343b42941f53 /README.rst
parent380df00f61e7ac2d0640f31b658fc853e4b8f9a0 (diff)
downloadpylint-git-32255df5608bb8b2d5b0bc05bf70712b61f44204.tar.gz
Adjut the wording to be less opinionated and mention the editable install
Diffstat (limited to 'README.rst')
-rw-r--r--README.rst21
1 files changed, 17 insertions, 4 deletions
diff --git a/README.rst b/README.rst
index 08c428c65..fe9a266a9 100644
--- a/README.rst
+++ b/README.rst
@@ -117,7 +117,14 @@ To run the test suite for a particular Python version, you can do::
tox -e py37
-If you want to run tests on a specific portion of the code use pytest_, (pytest-cov_) and your local python version::
+To run individual tests with ``tox``, you can do::
+
+ tox -e py37 -- -k name_of_the_test
+
+
+We use pytest_ for testing ``pylint``, which you can use without using ``tox`` for a faster development cycle.
+
+If you want to run tests on a specific portion of the code with pytest_, (pytest-cov_) and your local python version::
# ( pip install pytest-cov )
# Everything:
@@ -129,14 +136,20 @@ If you want to run tests on a specific portion of the code use pytest_, (pytest-
python3 -m pytest "tests/test_functional.py::test_functional[missing_kwoa_py3]"
-It can be more than 100 times faster than tox and you can also get the coverage.
-10000 times if you want to launch a single functional test. First, you
-need to clone astroid_ and install the last version from source::
+Do not forget to clone astroid_ and install the last version::
+
git clone https://github.com/PyCQA/astroid.git
+
+ # From source
python3 astroid/setup.py build sdist
pip3 install astroid/dist/astroid*.tar.gz
+ # Using an editable installation
+ cd astroid
+ python3 -m pip install -e .
+
+
For more detailed information, check the documentation.
.. _here: http://pylint.pycqa.org/en/latest/user_guide/installation.html