summaryrefslogtreecommitdiff
path: root/README.rst
diff options
context:
space:
mode:
authorPierre Sassoulas <pierre.sassoulas@gmail.com>2022-04-26 09:49:21 +0200
committerPierre Sassoulas <pierre.sassoulas@gmail.com>2022-04-28 13:09:08 +0200
commit72b9e83d0e48545a3cb5db18e0c724ec406ce9c2 (patch)
treefcf201df74638a4dc1f546cfa09c3fd85800f412 /README.rst
parent215bdf12f61b4e5ebc5e2b745a84f7c665491f90 (diff)
downloadpylint-git-72b9e83d0e48545a3cb5db18e0c724ec406ce9c2.tar.gz
Better documentation for development of pylint
Co-authored-by: Daniƫl van Noord <13665637+DanielNoord@users.noreply.github.com>
Diffstat (limited to 'README.rst')
-rw-r--r--README.rst37
1 files changed, 13 insertions, 24 deletions
diff --git a/README.rst b/README.rst
index aef1e34f1..c06543b07 100644
--- a/README.rst
+++ b/README.rst
@@ -106,45 +106,34 @@ Pylint is shipped with following additional commands:
Testing
-------
-We use tox_ and pytest-benchmark_ for running the test suite. You should be able to install it with::
+You should be able to install our tests dependencies with::
- pip install tox pytest pytest-benchmark
+ pip install -r requirements_test.txt
-
-To run the test suite for a particular Python version, you can do::
-
- tox -e py37
-
-
-To run individual tests with ``tox``, you can do::
-
- tox -e py37 -- -k name_of_the_test
-
-
-We use pytest_ for testing ``pylint``, which you can use without using ``tox`` for a faster development cycle.
-
-If you want to run tests on a specific portion of the code with pytest_, (pytest-cov_) and your local python version::
+You can then use pytest_ directly. If you want to run tests on a specific portion of the
+code with pytest_ and your local python version::
# ( pip install pytest-cov )
- # Everything:
- python3 -m pytest tests/
+ python3 -m pytest
# Everything in tests/message with coverage for the relevant code:
python3 -m pytest tests/message/ --cov=pylint.message
coverage html
# Only the functional test "missing_kwoa_py3":
python3 -m pytest "tests/test_functional.py::test_functional[missing_kwoa_py3]"
+You can also *optionally* install tox_. To run the test suite for a particular
+Python version, with tox you can do::
-Do not forget to clone astroid_ and install the last version::
+ tox -e py39
+To run individual tests with ``tox``, you can do::
- git clone https://github.com/PyCQA/astroid.git
+ tox -e py37 -- -k name_of_the_test
- # From source
- python3 astroid/setup.py build sdist
- pip3 install astroid/dist/astroid*.tar.gz
+If you're testing new change in astroid you need to clone astroid_ and install
+the last version::
- # Using an editable installation
+ git clone https://github.com/PyCQA/astroid.git
cd astroid
python3 -m pip install -e .