summaryrefslogtreecommitdiff
path: root/doc/Makefile
diff options
context:
space:
mode:
authorPierre Sassoulas <pierre.sassoulas@gmail.com>2022-05-15 20:12:16 +0200
committerPierre Sassoulas <pierre.sassoulas@gmail.com>2022-05-16 12:21:17 +0200
commit71f93af8cc1bc68021897f62c8a879f723af0355 (patch)
treec26704525ea6a28253b655168bdfd31c017c917b /doc/Makefile
parent62a0e88515c46c4c80dc41836cfa662a86a6a323 (diff)
downloadpylint-git-71f93af8cc1bc68021897f62c8a879f723af0355.tar.gz
Makefile that expect the requirements to be installed
Diffstat (limited to 'doc/Makefile')
-rw-r--r--doc/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/doc/Makefile b/doc/Makefile
index be90a2dfd..e7bca8aa9 100644
--- a/doc/Makefile
+++ b/doc/Makefile
@@ -38,14 +38,14 @@ help:
clean:
-rm -rf $(BUILDDIR)/*
-html:
- @echo
- @echo "Install dependencies"
- $(PIP) install furo
- @echo "Finished installing dependencies"
+build-html:
$(SPHINXBUILD) -b html $(ALLSPHINXOPTS) $(BUILDDIR)/html
+ @echo "HTML build complete"
+
+html: build-html
+ @echo "Install dependencies"
+ $(PIP) install -r requirements.txt
$(SPHINXBUILD) -b linkcheck $(ALLSPHINXOPTS) $(BUILDDIR)/linkcheck
- @echo
@echo "Link check complete; look for any errors in the above output " \
"or in $(BUILDDIR)/linkcheck/output.txt."