summaryrefslogtreecommitdiff
path: root/doc/Makefile
diff options
context:
space:
mode:
authorDaniël van Noord <13665637+DanielNoord@users.noreply.github.com>2022-04-13 12:20:14 +0200
committerDaniël van Noord <13665637+DanielNoord@users.noreply.github.com>2022-04-13 12:35:14 +0200
commit897ea1d8fa389d96593feef4bdd923f4edbaff13 (patch)
tree1227203736717bc4ca48c6f7b72203ddb4ea7ec5 /doc/Makefile
parentac036e45ff2d9fbcaf11b42d928364c993a5c384 (diff)
downloadpylint-git-897ea1d8fa389d96593feef4bdd923f4edbaff13.tar.gz
Update Sphinx makefiles with options used on readthedocs
Diffstat (limited to 'doc/Makefile')
-rw-r--r--doc/Makefile35
1 files changed, 8 insertions, 27 deletions
diff --git a/doc/Makefile b/doc/Makefile
index 278eea897..be90a2dfd 100644
--- a/doc/Makefile
+++ b/doc/Makefile
@@ -13,9 +13,9 @@ PYTHONPATH =
# Internal variables.
PAPEROPT_a4 = -D latex_paper_size=a4
PAPEROPT_letter = -D latex_paper_size=letter
-ALLSPHINXOPTS = -d $(BUILDDIR)/doctrees $(PAPEROPT_$(PAPER)) $(SPHINXOPTS) .
+ALLSPHINXOPTS = -d $(BUILDDIR)/doctrees -T -E -W --keep-going $(PAPEROPT_$(PAPER)) $(SPHINXOPTS) .
-.PHONY: help clean html dirhtml singlehtml pickle json htmlhelp qthelp devhelp epub latex latexpdf text man changes linkcheck doctest all
+.PHONY: help clean html dirhtml singlehtml pickle json htmlhelp qthelp devhelp epub latex latexpdf text man changes linkcheck
help:
@echo "Please use \`make <target>' where <target> is one of"
@@ -34,21 +34,21 @@ help:
@echo " man to make manual pages"
@echo " changes to make an overview of all changed/added/deprecated items"
@echo " linkcheck to check all external links for integrity"
- @echo " doctest to run all doctests embedded in the documentation (if enabled)"
clean:
-rm -rf $(BUILDDIR)/*
- -rm -f reference_guide/features.rst
- -rm -f extensions.rst
-html: features.rst extensions.rst
+html:
@echo
@echo "Install dependencies"
- $(PIP) install python-docs-theme
+ $(PIP) install furo
@echo "Finished installing dependencies"
$(SPHINXBUILD) -b html $(ALLSPHINXOPTS) $(BUILDDIR)/html
+ $(SPHINXBUILD) -b linkcheck $(ALLSPHINXOPTS) $(BUILDDIR)/linkcheck
@echo
- @echo "Build finished. The HTML pages are in $(BUILDDIR)/html."
+ @echo "Link check complete; look for any errors in the above output " \
+ "or in $(BUILDDIR)/linkcheck/output.txt."
+
dirhtml:
$(SPHINXBUILD) -b dirhtml $(ALLSPHINXOPTS) $(BUILDDIR)/dirhtml
@@ -132,22 +132,3 @@ linkcheck:
@echo
@echo "Link check complete; look for any errors in the above output " \
"or in $(BUILDDIR)/linkcheck/output.txt."
-
-doctest:
- $(SPHINXBUILD) -b doctest $(ALLSPHINXOPTS) $(BUILDDIR)/doctest
- @echo "Testing of doctests in the sources finished, look at the " \
- "results in $(BUILDDIR)/doctest/output.txt."
-
-
-extensions.rst: exts/pylint_extensions.py
-extensions.rst: $(shell find ../pylint/extensions -type f -regex '.*\.py')
-extensions.rst: $(shell find ../pylint/extensions -type f -regex '.*\.rst')
- rm -f extensions.rst
- PYTHONPATH=$(PYTHONPATH) $(PYTHON) ./exts/pylint_extensions.py
-
-features.rst: exts/pylint_features.py
-features.rst: $(shell find ../pylint/checkers -type f -regex '.*\.py')
- rm -f features.rst
- PYTHONPATH=$(PYTHONPATH) $(PYTHON) ./exts/pylint_features.py
-
-messages: $(PYTHONPATH) $(PYTHON) ./exts/pylint_messages.py