summaryrefslogtreecommitdiff
path: root/examples/pyproject.toml
diff options
context:
space:
mode:
authorPierre Sassoulas <pierre.sassoulas@gmail.com>2023-03-07 22:57:04 +0100
committerGitHub <noreply@github.com>2023-03-07 22:57:04 +0100
commitee2e63519b15683d8c93626695c97936eb956ebf (patch)
treef390f30ae273f8dd4c1829e32e079a18ab71ceba /examples/pyproject.toml
parentca2549708acd3ede6621c56477b1c0333eb62254 (diff)
downloadpylint-git-ee2e63519b15683d8c93626695c97936eb956ebf.tar.gz
Bump pylint to 2.17.0, update changelog (#8395)
Diffstat (limited to 'examples/pyproject.toml')
-rw-r--r--examples/pyproject.toml12
1 files changed, 11 insertions, 1 deletions
diff --git a/examples/pyproject.toml b/examples/pyproject.toml
index 71490d860..1608d2cbb 100644
--- a/examples/pyproject.toml
+++ b/examples/pyproject.toml
@@ -83,6 +83,12 @@ py-version = "3.10"
# Discover python modules and packages in the file system subtree.
# recursive =
+# Add paths to the list of the source roots. Supports globbing patterns. The
+# source root is an absolute path or a path relative to the current working
+# directory used to determine a package namespace for modules located under the
+# source root.
+# source-roots =
+
# When enabled, pylint would attempt to guess common misconfiguration and emit
# user-friendly hints instead of false-positive error messages.
suggestion-mode = true
@@ -200,6 +206,10 @@ no-docstring-rgx = "^_"
# decorators are taken in consideration only for invalid-name.
property-classes = ["abc.abstractproperty"]
+# Regular expression matching correct type alias names. If left empty, type alias
+# names will be checked with the set naming style.
+# typealias-rgx =
+
# Regular expression matching correct type variable names. If left empty, type
# variable names will be checked with the set naming style.
# typevar-rgx =
@@ -220,7 +230,7 @@ defining-attr-methods = ["__init__", "__new__", "setUp", "__post_init__"]
# List of member names, which should be excluded from the protected access
# warning.
-exclude-protected = ["_asdict", "_fields", "_replace", "_source", "_make"]
+exclude-protected = ["_asdict", "_fields", "_replace", "_source", "_make", "os._exit"]
# List of valid names for the first argument in a class method.
valid-classmethod-first-arg = ["cls"]