summaryrefslogtreecommitdiff
path: root/examples
diff options
context:
space:
mode:
authorCubicpath <Cubicpath@protonmail.com>2022-11-19 08:52:54 -0500
committerGitHub <noreply@github.com>2022-11-19 14:52:54 +0100
commit44d51b022a1378fb486a4655490bbe7585098189 (patch)
treefd1fe56e84f5b61642f5f7014bad1857ed11e05d /examples
parent53974e8e6711cec3e5659c26855cec6fada5a9cf (diff)
downloadpylint-git-44d51b022a1378fb486a4655490bbe7585098189.tar.gz
Fix `valid-metaclass-classmethod-first-arg` default value (#7791)
* Change default value to "mcs" * Fix functional tests to use "mcs" for first MetaClass classmethod arg
Diffstat (limited to 'examples')
-rw-r--r--examples/pylintrc2
-rw-r--r--examples/pyproject.toml2
2 files changed, 2 insertions, 2 deletions
diff --git a/examples/pylintrc b/examples/pylintrc
index 608a8f269..61a9361d6 100644
--- a/examples/pylintrc
+++ b/examples/pylintrc
@@ -260,7 +260,7 @@ exclude-protected=_asdict,
valid-classmethod-first-arg=cls
# List of valid names for the first argument in a metaclass class method.
-valid-metaclass-classmethod-first-arg=cls
+valid-metaclass-classmethod-first-arg=mcs
[DESIGN]
diff --git a/examples/pyproject.toml b/examples/pyproject.toml
index c02538a7c..98cb39bb9 100644
--- a/examples/pyproject.toml
+++ b/examples/pyproject.toml
@@ -222,7 +222,7 @@ exclude-protected = ["_asdict", "_fields", "_replace", "_source", "_make"]
valid-classmethod-first-arg = ["cls"]
# List of valid names for the first argument in a metaclass class method.
-valid-metaclass-classmethod-first-arg = ["cls"]
+valid-metaclass-classmethod-first-arg = ["mcs"]
[tool.pylint.design]
# List of regular expressions of class ancestor names to ignore when counting