summaryrefslogtreecommitdiff
path: root/examples
diff options
context:
space:
mode:
authorPierre Sassoulas <pierre.sassoulas@gmail.com>2023-04-26 21:50:45 +0200
committerPierre Sassoulas <pierre.sassoulas@gmail.com>2023-05-02 20:01:39 +0200
commit918f4624d76197bec7cc54467f0281ff63c19c5a (patch)
tree1a7ca06809bff250669d6ca7faa04ab30acd0668 /examples
parent26686d544eab7236a92e56cc90c34b6e3a37f473 (diff)
downloadpylint-git-918f4624d76197bec7cc54467f0281ff63c19c5a.tar.gz
Merge the empty-string extensions to 'implicit_booleaness_checker'
Diffstat (limited to 'examples')
-rw-r--r--examples/pylintrc4
-rw-r--r--examples/pyproject.toml4
2 files changed, 5 insertions, 3 deletions
diff --git a/examples/pylintrc b/examples/pylintrc
index 16284083e..d496b6b90 100644
--- a/examples/pylintrc
+++ b/examples/pylintrc
@@ -428,13 +428,15 @@ disable=raw-checker-failed,
suppressed-message,
useless-suppression,
deprecated-pragma,
+ use-implicit-booleaness-not-comparison-to-string,
+ use-implicit-booleaness-not-comparison-to-zero,
use-symbolic-message-instead
# Enable the message, report, category or checker with the given id(s). You can
# either give multiple identifier separated by comma (,) or put this option
# multiple time (only on the command line, not in the configuration file where
# it should appear only once). See also the "--disable" option for examples.
-enable=c-extension-no-member
+enable=
[METHOD_ARGS]
diff --git a/examples/pyproject.toml b/examples/pyproject.toml
index f9a493c89..6aba10140 100644
--- a/examples/pyproject.toml
+++ b/examples/pyproject.toml
@@ -365,13 +365,13 @@ confidence = ["HIGH", "CONTROL_FLOW", "INFERENCE", "INFERENCE_FAILURE", "UNDEFIN
# --enable=similarities". If you want to run only the classes checker, but have
# no Warning level messages displayed, use "--disable=all --enable=classes
# --disable=W".
-disable = ["raw-checker-failed", "bad-inline-option", "locally-disabled", "file-ignored", "suppressed-message", "useless-suppression", "deprecated-pragma", "use-symbolic-message-instead"]
+disable = ["raw-checker-failed", "bad-inline-option", "locally-disabled", "file-ignored", "suppressed-message", "useless-suppression", "deprecated-pragma", "use-implicit-booleaness-not-comparison-to-string", "use-implicit-booleaness-not-comparison-to-zero", "use-symbolic-message-instead"]
# Enable the message, report, category or checker with the given id(s). You can
# either give multiple identifier separated by comma (,) or put this option
# multiple time (only on the command line, not in the configuration file where it
# should appear only once). See also the "--disable" option for examples.
-enable = ["c-extension-no-member"]
+# enable =
[tool.pylint.method_args]
# List of qualified names (i.e., library.method) which require a timeout