summaryrefslogtreecommitdiff
path: root/examples
diff options
context:
space:
mode:
authorPierre Sassoulas <pierre.sassoulas@gmail.com>2023-02-01 10:34:04 +0100
committerPierre Sassoulas <pierre.sassoulas@gmail.com>2023-02-01 11:50:49 +0100
commitdcb0198d164b7f4306f60d854a6bd97ff65a62a4 (patch)
treead9065cb1629f54c943962c70f51baacecad6fcc /examples
parent77e562cd8c3e04c2b2a4267e740864b7793028e5 (diff)
downloadpylint-git-dcb0198d164b7f4306f60d854a6bd97ff65a62a4.tar.gz
Bump pylint to 2.16.0, update changelogv2.16.0
Diffstat (limited to 'examples')
-rw-r--r--examples/pylintrc3
-rw-r--r--examples/pyproject.toml3
2 files changed, 6 insertions, 0 deletions
diff --git a/examples/pylintrc b/examples/pylintrc
index a69f91575..1cf9639a1 100644
--- a/examples/pylintrc
+++ b/examples/pylintrc
@@ -350,6 +350,9 @@ single-line-if-stmt=no
# one.
allow-any-import-level=
+# Allow explicit reexports by alias from a package __init__.
+allow-reexport-from-package=no
+
# Allow wildcard imports from modules that define __all__.
allow-wildcard-with-all=no
diff --git a/examples/pyproject.toml b/examples/pyproject.toml
index d3b8b9052..71490d860 100644
--- a/examples/pyproject.toml
+++ b/examples/pyproject.toml
@@ -301,6 +301,9 @@ max-module-lines = 1000
# List of modules that can be imported at any level, not just the top level one.
# allow-any-import-level =
+# Allow explicit reexports by alias from a package __init__.
+# allow-reexport-from-package =
+
# Allow wildcard imports from modules that define __all__.
# allow-wildcard-with-all =