summaryrefslogtreecommitdiff
path: root/examples
diff options
context:
space:
mode:
authorJacob Walls <jacobtylerwalls@gmail.com>2022-12-05 16:52:17 -0500
committerGitHub <noreply@github.com>2022-12-05 22:52:17 +0100
commitf860e3fe1c03be81e16732123a1e0cdb247db47f (patch)
tree0dfeaef9382e3f1f5b080570438f250a21abe3dd /examples
parentffef6f0c0e0ad1e54ea412f77e38a8628f3d32c8 (diff)
downloadpylint-git-f860e3fe1c03be81e16732123a1e0cdb247db47f.tar.gz
Add flag `--clear-cache-post-run` to support server-like usage (#7802)
Use this flag if you expect the linted files to be altered between runs, for instance, if using pylint in a server-like mode. The flag clear's astroid's in-memory caches.
Diffstat (limited to 'examples')
-rw-r--r--examples/pylintrc4
-rw-r--r--examples/pyproject.toml4
2 files changed, 8 insertions, 0 deletions
diff --git a/examples/pylintrc b/examples/pylintrc
index 61a9361d6..aa9db9dcf 100644
--- a/examples/pylintrc
+++ b/examples/pylintrc
@@ -5,6 +5,10 @@
# only in one or another interpreter, leading to false positives when analysed.
analyse-fallback-blocks=no
+# Clear in-memory caches upon conclusion of linting. Useful if running pylint in
+# a server-like mode.
+clear-cache-post-run=no
+
# Load and enable all available extensions. Use --list-extensions to see a list
# all available extensions.
#enable-all-extensions=
diff --git a/examples/pyproject.toml b/examples/pyproject.toml
index 98cb39bb9..16f528327 100644
--- a/examples/pyproject.toml
+++ b/examples/pyproject.toml
@@ -4,6 +4,10 @@
# one or another interpreter, leading to false positives when analysed.
# analyse-fallback-blocks =
+# Clear in-memory caches upon conclusion of linting. Useful if running pylint in
+# a server-like mode.
+# clear-cache-post-run =
+
# Always return a 0 (non-error) status code, even if lint errors are found. This
# is primarily useful in continuous integration scripts.
# exit-zero =