summaryrefslogtreecommitdiff
path: root/pylint/utils
diff options
context:
space:
mode:
authorPierre Sassoulas <pierre.sassoulas@gmail.com>2022-03-01 16:04:49 +0100
committerPierre Sassoulas <pierre.sassoulas@gmail.com>2022-03-24 13:06:15 +0100
commitec4a3f7f1eac9e605b35d1ac56680e1608c48be3 (patch)
tree5cf16665b7797bbe17e71f0f886a744e83bd034a /pylint/utils
parent9e0baf370a15fecf3360996a6a2ead688fc61894 (diff)
downloadpylint-git-ec4a3f7f1eac9e605b35d1ac56680e1608c48be3.tar.gz
Add a pre-commit hook to check the copyright notice
Fix the existing file so they have a notice. No header for setup.py or examples or doc
Diffstat (limited to 'pylint/utils')
-rw-r--r--pylint/utils/__init__.py2
-rw-r--r--pylint/utils/ast_walker.py2
-rw-r--r--pylint/utils/docs.py3
-rw-r--r--pylint/utils/file_state.py2
-rw-r--r--pylint/utils/linterstats.py2
-rw-r--r--pylint/utils/pragma_parser.py2
-rw-r--r--pylint/utils/utils.py3
7 files changed, 8 insertions, 8 deletions
diff --git a/pylint/utils/__init__.py b/pylint/utils/__init__.py
index 7406f7ec6..51813f994 100644
--- a/pylint/utils/__init__.py
+++ b/pylint/utils/__init__.py
@@ -1,6 +1,6 @@
# Licensed under the GPL: https://www.gnu.org/licenses/old-licenses/gpl-2.0.html
# For details: https://github.com/PyCQA/pylint/blob/main/LICENSE
-# Copyright (c) https://github.com/PyCQA/pylint/graphs/contributors
+# Copyright (c) https://github.com/PyCQA/pylint/blob/main/CONTRIBUTORS.txt
"""Some various utilities and helper classes, most of them used in the
main pylint class
diff --git a/pylint/utils/ast_walker.py b/pylint/utils/ast_walker.py
index 08fc3af92..415bd97dd 100644
--- a/pylint/utils/ast_walker.py
+++ b/pylint/utils/ast_walker.py
@@ -1,6 +1,6 @@
# Licensed under the GPL: https://www.gnu.org/licenses/old-licenses/gpl-2.0.html
# For details: https://github.com/PyCQA/pylint/blob/main/LICENSE
-# Copyright (c) https://github.com/PyCQA/pylint/graphs/contributors
+# Copyright (c) https://github.com/PyCQA/pylint/blob/main/CONTRIBUTORS.txt
import collections
import traceback
diff --git a/pylint/utils/docs.py b/pylint/utils/docs.py
index 22412b803..b6fb877f0 100644
--- a/pylint/utils/docs.py
+++ b/pylint/utils/docs.py
@@ -1,6 +1,7 @@
# Licensed under the GPL: https://www.gnu.org/licenses/old-licenses/gpl-2.0.html
# For details: https://github.com/PyCQA/pylint/blob/main/LICENSE
-# Copyright (c) https://github.com/PyCQA/pylint/graphs/contributors
+# Copyright (c) https://github.com/PyCQA/pylint/blob/main/CONTRIBUTORS.txt
+
"""Various helper functions to create the docs of a linter object."""
import sys
diff --git a/pylint/utils/file_state.py b/pylint/utils/file_state.py
index b7f09a6b9..b820affcc 100644
--- a/pylint/utils/file_state.py
+++ b/pylint/utils/file_state.py
@@ -1,6 +1,6 @@
# Licensed under the GPL: https://www.gnu.org/licenses/old-licenses/gpl-2.0.html
# For details: https://github.com/PyCQA/pylint/blob/main/LICENSE
-# Copyright (c) https://github.com/PyCQA/pylint/graphs/contributors
+# Copyright (c) https://github.com/PyCQA/pylint/blob/main/CONTRIBUTORS.txt
import collections
import sys
diff --git a/pylint/utils/linterstats.py b/pylint/utils/linterstats.py
index e09e0ce43..f7ca05f61 100644
--- a/pylint/utils/linterstats.py
+++ b/pylint/utils/linterstats.py
@@ -1,6 +1,6 @@
# Licensed under the GPL: https://www.gnu.org/licenses/old-licenses/gpl-2.0.html
# For details: https://github.com/PyCQA/pylint/blob/main/LICENSE
-# Copyright (c) https://github.com/PyCQA/pylint/graphs/contributors
+# Copyright (c) https://github.com/PyCQA/pylint/blob/main/CONTRIBUTORS.txt
import sys
from typing import Dict, List, Optional, Set, cast
diff --git a/pylint/utils/pragma_parser.py b/pylint/utils/pragma_parser.py
index 090a336fc..01cdf440a 100644
--- a/pylint/utils/pragma_parser.py
+++ b/pylint/utils/pragma_parser.py
@@ -1,6 +1,6 @@
# Licensed under the GPL: https://www.gnu.org/licenses/old-licenses/gpl-2.0.html
# For details: https://github.com/PyCQA/pylint/blob/main/LICENSE
-# Copyright (c) https://github.com/PyCQA/pylint/graphs/contributors
+# Copyright (c) https://github.com/PyCQA/pylint/blob/main/CONTRIBUTORS.txt
import re
from collections import namedtuple
diff --git a/pylint/utils/utils.py b/pylint/utils/utils.py
index 835351ec3..6a60cd8e9 100644
--- a/pylint/utils/utils.py
+++ b/pylint/utils/utils.py
@@ -1,7 +1,6 @@
# Licensed under the GPL: https://www.gnu.org/licenses/old-licenses/gpl-2.0.html
# For details: https://github.com/PyCQA/pylint/blob/main/LICENSE
-# Copyright (c) https://github.com/PyCQA/pylint/graphs/contributors
-
+# Copyright (c) https://github.com/PyCQA/pylint/blob/main/CONTRIBUTORS.txt
try:
import isort.api