summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorPierre Sassoulas <pierre.sassoulas@gmail.com>2023-03-02 21:19:56 +0100
committerGitHub <noreply@github.com>2023-03-02 21:19:56 +0100
commit4de654512e8c1219046f2f49664b6c9f66946e84 (patch)
tree6b7b4dd14e48198829080f98893925481c2a7011 /pyproject.toml
parentb5aab35a6f20efad94ae8da07392fad6d1c28aad (diff)
downloadpylint-git-4de654512e8c1219046f2f49664b6c9f66946e84.tar.gz
[pre-commit] Transition from flake8/autoflake to ruff (#8372)
ruff is faster and support pyproject.toml. flake8-typing-import is not implemented but it checks for things in python version < 3.7.2 that we do not support.
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml9
1 files changed, 6 insertions, 3 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 80547df05..1c8a915ac 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -130,10 +130,13 @@ module = [
"pytest",
"sphinx.*",
]
+
[tool.ruff]
-select = ["E", "F", "B"]
+select = ["E", "F", "W", "B"]
ignore = [
"B905", # Not enforced previousely
]
-fixable = ["E", "F", "B"]
-line-length = 125
+fixable = ["E", "F", "W", "B"]
+# ruff is less lenient than pylint and does not make any exceptions
+# (for docstrings, strings and comments in particular).
+line-length = 115