summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorSandro Tosi <sandrotosi@users.noreply.github.com>2022-12-14 13:43:59 -0500
committerGitHub <noreply@github.com>2022-12-14 19:43:59 +0100
commit5a93635a4a220b16b83b859c2c7f4421ce8d05cd (patch)
tree67aaa1c071b381dcd92a8e7e8075bf00bb180a5d /pyproject.toml
parentd042f728ff8cb5119b6a9835e2d468641e24d684 (diff)
downloadpylint-git-5a93635a4a220b16b83b859c2c7f4421ce8d05cd.tar.gz
fix: bump dill to >= 0.3.6, prevents tests hanging with python3.11 (#7918)
Co-authored-by: Pierre Sassoulas <pierre.sassoulas@gmail.com>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 0dadcf6c3..88733b5e3 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -33,7 +33,8 @@ classifiers = [
]
requires-python = ">=3.7.2"
dependencies = [
- "dill>=0.2",
+ "dill>=0.2;python_version<'3.11'",
+ "dill>=0.3.6;python_version>='3.11'",
"platformdirs>=2.2.0",
# Also upgrade requirements_test_min.txt.
# Pinned to dev of second minor update to allow editable installs and fix primer issues,