summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorPierre Sassoulas <pierre.sassoulas@gmail.com>2023-03-10 21:38:06 +0100
committerPierre Sassoulas <pierre.sassoulas@gmail.com>2023-03-10 23:12:37 +0100
commit5c51bc5259553606f78230a5c0ca4ea3ccbb75c6 (patch)
treeb2fac62450e2a17781369560dc828de7728a2696 /pyproject.toml
parent0d26e3cda507bb1a5bca21a0a6e3b86a8ffe92b6 (diff)
downloadpylint-git-5c51bc5259553606f78230a5c0ca4ea3ccbb75c6.tar.gz
[pre-commit] Configure ruff to sort import
I'm not sure if ruff handle first party / third parties, but it's good enough for the doc
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml26
1 files changed, 21 insertions, 5 deletions
diff --git a/pyproject.toml b/pyproject.toml
index e5ab0d735..238b1fcb0 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -132,11 +132,27 @@ module = [
]
[tool.ruff]
-select = ["E", "F", "W", "B"]
-ignore = [
- "B905", # Not enforced previousely
-]
-fixable = ["E", "F", "W", "B"]
+
# ruff is less lenient than pylint and does not make any exceptions
# (for docstrings, strings and comments in particular).
line-length = 115
+
+select = [
+ "E", # pycodestyle
+ "F", # pyflakes
+ "W", # pycodestyle
+ "B", # bugbear
+ "I", # isort
+]
+
+ignore = [
+ "B905", # `zip()` without an explicit `strict=` parameter
+]
+
+fixable = [
+ "E", # pycodestyle
+ "F", # pyflakes
+ "W", # pycodestyle
+ "B", # bugbear
+ "I", # isort
+]