summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorPierre Sassoulas <pierre.sassoulas@gmail.com>2022-09-30 21:56:22 +0200
committerGitHub <noreply@github.com>2022-09-30 21:56:22 +0200
commit644f3fdb4591e14faf67050de4182d470f901662 (patch)
treed461be0f56a9c6f04dd38008914098c5bd45125b /pyproject.toml
parentaca8dd546e6ec03d169eb84d7421d4a1427920ce (diff)
downloadpylint-git-644f3fdb4591e14faf67050de4182d470f901662.tar.gz
Use 3.11 for Github actions (#6551)
Use ``dill-pylint`` (our own version of dill) because dill's 0.3.6 release is taking forever. Closes #5920 Co-authored-by: Daniƫl van Noord <13665637+DanielNoord@users.noreply.github.com>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml5
1 files changed, 4 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index f8093a627..62cf702e8 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -24,6 +24,7 @@ classifiers = [
"Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3.9",
"Programming Language :: Python :: 3.10",
+ "Programming Language :: Python :: 3.11",
"Programming Language :: Python :: Implementation :: CPython",
"Programming Language :: Python :: Implementation :: PyPy",
"Topic :: Software Development :: Debuggers",
@@ -32,7 +33,9 @@ classifiers = [
]
requires-python = ">=3.7.2"
dependencies = [
- "dill>=0.2",
+ # TODO: Remove dill-pylint once dill 0.3.6 is released
+ "dill>=0.2;python_version<'3.11'",
+ "dill-pylint>=0.3.6.dev0;python_version>='3.11'",
"platformdirs>=2.2.0",
# Also upgrade requirements_test_min.txt and all the CACHE_VERSION in
# github actions if you are bumping astroid.