summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorJacob Walls <jacobtylerwalls@gmail.com>2022-11-23 04:04:58 -0500
committerGitHub <noreply@github.com>2022-11-23 10:04:58 +0100
commit694d3024dbfea06aefd9288a99d7a375fe100859 (patch)
treea5c9db9cfbbbf742efa4f84b4038ba16154d5783 /pyproject.toml
parente2ef840528de633fdf8b826a9d7068345d8f371f (diff)
downloadpylint-git-694d3024dbfea06aefd9288a99d7a375fe100859.tar.gz
Fail pytest runs on warnings (#7809)
* Catch DeprecationWarning in pyreverse Follow-up to #6869 * Patch use of deprecated `astroid.node_classes` in test * Ignore DeprecationWarning in test_parseable_output_regression Co-authored-by: Pierre Sassoulas <pierre.sassoulas@gmail.com>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 27e6a36e5..401106a3b 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -89,6 +89,7 @@ test = "pytest"
testpaths = ["tests"]
python_files = ["*test_*.py"]
addopts = "--strict-markers"
+filterwarnings = "error"
markers = [
"primer_stdlib: Checks for crashes and errors when running pylint on stdlib",
"primer_external_batch_one: Checks for crashes and errors when running pylint on external libs (batch one)",