summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorChristian Clauss <cclauss@me.com>2022-09-22 13:23:08 +0200
committerDaniƫl van Noord <13665637+DanielNoord@users.noreply.github.com>2022-09-22 20:22:31 +0200
commitd2056b3a675183f1165c8c8153302a7572bead97 (patch)
tree279f85de7b6df4bd257ef2c58b7340e6a12bdfa9 /pyproject.toml
parentea86fcf71af6f2e39ce1fdcab5f8bf05b4d32082 (diff)
downloadpylint-git-d2056b3a675183f1165c8c8153302a7572bead97.tar.gz
Migrate configs for isort, mypy, and pytest into pyproject.toml
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml47
1 files changed, 47 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 5950fdffd..567274153 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -79,3 +79,50 @@ pylint = ["testutils/testing_pylintrc"]
[tool.setuptools.dynamic]
version = {attr = "pylint.__pkginfo__.__version__"}
+
+[tool.aliases]
+test = "pytest"
+
+[tool.pytest.ini_options]
+testpaths = ["tests"]
+python_files = ["*test_*.py"]
+addopts = "--strict-markers"
+markers = [
+ "primer_stdlib: Checks for crashes and errors when running pylint on stdlib",
+ "primer_external_batch_one: Checks for crashes and errors when running pylint on external libs (batch one)",
+ "benchmark: Baseline of pylint performance, if this regress something serious happened",
+ "timeout: Marks from pytest-timeout.",
+ "needs_two_cores: Checks that need 2 or more cores to be meaningful",
+]
+
+[tool.isort]
+profile = "black"
+known_third_party = ["platformdirs", "astroid", "sphinx", "isort", "pytest", "mccabe", "six", "toml"]
+skip_glob = ["tests/functional/**", "tests/input/**", "tests/extensions/data/**", "tests/regrtest_data/**", "tests/data/**", "astroid/**", "venv/**"]
+src_paths = ["pylint"]
+
+[tool.mypy]
+scripts_are_modules = true
+warn_unused_ignores = true
+show_error_codes = true
+enable_error_code = "ignore-without-code"
+strict = true
+# TODO: Remove this once pytest has annotations
+disallow_untyped_decorators = false
+
+[[tool.mypy.overrides]]
+ignore_missing_imports = true
+module = [
+ "_pytest.*",
+ "_string",
+ "astroid.*",
+ "contributors_txt",
+ "coverage",
+ "dill",
+ "enchant.*",
+ "git.*",
+ "mccabe",
+ "pytest_benchmark.*",
+ "pytest",
+ "sphinx.*",
+]